by LJB77 Valued Contributor
Valued Contributor

Re: Got new Apple Watch - LTE doesn't work !

I've been having the same problem, but have now got through it and been able to register. It would only work over cellular, though. With wifi I ended up getting passed the 'not set up' to 'oops, something's gone wrong'.

by michaelsft Valued Contributor
Valued Contributor

Re: Got new Apple Watch - LTE doesn't work !

Thanks Lee_H - I totally knew I could so the obvious question is, what's going on?!

 

Will look out for your updates.

by michaelsft Valued Contributor
Valued Contributor

Re: Got new Apple Watch - LTE doesn't work !

I'm using cellular, do I have to turn off wifi on the watch or something maybe?

by MOONPIG Investigator
Investigator

Re: Got new Apple Watch - LTE doesn't work !

Turned my phone off two mins ago and back on again and I now have it saying Activating with a spinning wheel. Shows some apps below with info about data usege. 

 

Data not working yet.

by
EE Employee

Re: Got new Apple Watch - LTE doesn't work !

Hi @MOONPIG

 

Please do keep us up to date on how you get on.

 

Many thanks,

 

Lee

by MOONPIG Investigator
Investigator

Re: Got new Apple Watch - LTE doesn't work !

It now says the plan on the watch as “EE” but has no connection. I think i will take 30mins for the sim to start working. 

 

by robdn Established Contributor
Established Contributor

Re: Got new Apple Watch - LTE doesn't work !

In my case I can now click on the setup button, I authenticate, select a plan and...

 

a new error, with EE logo.

 

"Oops. It looks like there was a slight problem getting some information here.

 

Click cancel to start again.

 

If this keeps happening call us on 150 and quote code 012"

 

Anything on that Lee?

Highlighted
by michaelsft Valued Contributor
Valued Contributor

Re: Got new Apple Watch - LTE doesn't work !

When I start the app afresh it says EE Loading Plan, the wheel spins and then it gives me the original error. Turned off and on twice. Nothing else I can do at my end. This is rather poor.

by robdn Established Contributor
Established Contributor

Re: Got new Apple Watch - LTE doesn't work !

New error.

 

"Our system checks show that you're not currently eligable to buy an additiona line for this device

There are a few reasons this happens. Call us on 150 and quote code 007, and we will look into it for you."

by retrospek Established Contributor
Established Contributor

Re: Got new Apple Watch - LTE doesn't work !

I'm not getting any of this - still doesn't work for me and still showing the error: "This account is not ready to use with Apple Watch"

by robdn Established Contributor
Established Contributor

Re: Got new Apple Watch - LTE doesn't work !

It ain't resolved.

 

Watch team said that this is still the known issue with SIM only plans.

 

 

by MOONPIG Investigator
Investigator

Re: Got new Apple Watch - LTE doesn't work !

Still no connection on the watch but its all set up. 

 

I’m on a sim only plan.

 

will update again soon if it gets a connection.

 

https://ibb.co/iwhM8k

 

by MOONPIG Investigator
Investigator

Re: Got new Apple Watch - LTE doesn't work !

It’s working!!!!!!!

 

https://ibb.co/moA2EQ

 

 

 

by
EE Employee

Re: Got new Apple Watch - LTE doesn't work !

Hi All,

 

This is still being looked into.

 

Soon as I have any further information I will let you know.

 

Many thanks,

 

Lee

by bazooka-joe Established Contributor
Established Contributor

Re: Got new Apple Watch - LTE doesn't work !

So is the issue with Apple or EE because both parties seem to be accepting liability.  Does it require an update to WatchOS4 and an update from EE to accept sim only plans?

by robdn Established Contributor
Established Contributor

Re: Got new Apple Watch - LTE doesn't work !

@Lee_H we get that.

It would be quite awesome if it could be looked into 'faster'. This definitely spoils the equipment.

 

I've only moved to EE to have it worked, and I assumed, that as the official launch partner, EE will have it working, out of the box, from the first hour.

 

One would expect this to be tested beforehand. You're testing on a production envirnoment and on your Customers.

 

It's a disappointing experience.

by
EE Employee

Re: Got new Apple Watch - LTE doesn't work !

Hi @robdn

 

What is customer service saying when you are calling in and quoting the relevant codes?

 

Many thanks,

 

Lee

by robdn Established Contributor
Established Contributor

Re: Got new Apple Watch - LTE doesn't work !

That there is a note on my account that I've reported the issue with the 'Setup mobile data' button disabled, that apparently is now resolved, and as such since this was not cleared they won't bother any more troubleshooting for this apparently new issue.

 

This is a new contract so my wild guess is that it's no longer the reported issue, but now  it's an account issue with fraud checking/billing/credit that prevents adding a 'new line' to a barely opened account.

 

If you have any power to have it checked, I'm happy to PM the mobile number.

 

D

by Fozzy2670 Established Contributor
Established Contributor

Re: Got new Apple Watch - LTE doesn't work !

OMG !!  What are EE playing at???

by
EE Employee

Re: Got new Apple Watch - LTE doesn't work !

Hi @robdn

 

What have customer services advising on how to resolve this issue.

 

Many thanks,

 

Lee

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.