by brisuth Investigator
Investigator

Pixel unlock stopped working after installing android 8 beta

here in UK got pixel from my provider ee , my O2 and my vodaphone SIM card when inserted into my phone would not work I had message to contact my provider , I paid nine pounds to ee to unlock my handset so I could use a different carriers SIM card , after a few days I received a message telling me this was done, I was running beta 3 at the time and no matter what SIM I tried it would not work , I came across some information that the ee build number on original stock ROM had to be different from the one I had on beta, I signed out of beta programme restored phone and every simcard I tried worked fine, I enrolled in beta programme again with my O2 simcard working in phone and as soon as it restarted I had no service could not call or text or use mobile data, put ee SIM card in and everything worked tried turning phone on and off tried all different network SIM cards and only ee works , went back to nougat and every network carrier works again is the build number tied in with SIM unlock

4 REPLIES 4
by Grand Master
Grand Master

Re: Pixel unlock stopped working after installing android 8 beta

@brisuth  You need to take that up with google. After all it is a beta so there will be issues. 

by
EE Community Support Team

Re: Pixel unlock stopped working after installing android 8 beta

Hi @brisuth,

 

Welcome to the EE Community.

 

As @Chris_B said, beta software can (and usually will) have bugs that affect various features of your phone.

 

If the beta software is causing you issues, it's best to uninstall and wait for a newer version.

 

Thanks

 

James

by brisuth Investigator
Investigator

Re: Pixel unlock stopped working after installing android 8 beta


@James_B wrote:

Hi @brisuth,

 

Welcome to the EE Community.

 

As @Chris_B said, beta software can (and usually will) have bugs that affect various features of your phone.

 

If the beta software is causing you issues, it's best to uninstall and wait for a newer version.

 

Thanks

 

James


Ok so I went back to stock on 20th august my SIM unlock is working again 2 three ,o2 and Vodafone simcards all working and next day I install official ota update to android 8 and my unlock is gone , spoke to EE and unlocking team who sent unlock request again and says was successful but my phone remains locked to EE,  what I am guessing at is prior to 21st august my phone being unlocked was down to the correct EE UK purchased build number being there and the beta candidate release obviously not matching something, 

When I installed official release of android 8 I did not realize until now I was still signed up for beta and signed out my device and as soon as did I got the September 5 security update that changed my build number again and I am wondering if beta had left me on incorrect build for my UK purchased pixel 

by
EE Employee

Re: Pixel unlock stopped working after installing android 8 beta

Hi @brisuth and welcome to the community.

 

I have sent you a private message to gain some help for you.

 

Many thanks,

 

Lee

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.