by Graemeaskes
Explorer

Text messages won’t send

I’m visiting the UK and got a prepaid EE SIM card. After putting it in I haven’t been able to send or receive text messages. Not sure what the process is. But it always says “could not deliver” using an iPhone 8 plus

3 REPLIES 3
by Grand Master
Grand Master

Re: Text messages won’t send

@Graemeaskes : For sending texts, check your phone has the Message Centre no. setting for EE as +447958879879. Maybe it's still got your home network's one.

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Thumbs Up" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC
by Graemeaskes
Explorer

Re: Text messages won’t send

How do I check and change this? Thank you

by Grand Master
Grand Master

Re: Text messages won’t send

I don't know the iPhone but on most phones it's under the Messaging app's settimgs.

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Thumbs Up" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.