by PaulecoW
Visitor

Why cant I use 4g in Switzerland

I am in Geneva for a few weeks. Having been frustrated by the slow speeds and the fact that 4G isnt an option in the 'Mobile Networks' drop down I called EE helpline. The lady told me: 1. I was in France even though I assured her I wasnt; 2. they dont have 4G in Switzerland - I checked & its 4G LTE in Geneva; I must have an old phone - its a Samsung S8. I persevered and she put me on hold for 4.5mins while she spoke to 2nd line technical (she is technical front-line!!!). The answer I then got was that Switzerland does have good 4G but the deal EE have with all operators there is not to offer 4G if roaming. So this must be since the EU rules on same roaming charges everywhere (Switzerland is included). Only option she said is to buy a local SIM. I will be calling Vodafone tomorrow!

1 SOLUTION

Accepted Solutions
by
EE Employee
Solution

Re: Why cant I use 4g in Switzerland

Hi @PaulecoW and welcome to the community.

 

So I can try and help, please may I get you to perform a manual network search and choose a network other than what you are on.

 

iPhone: Go to Settings > Carrier and turn off Automatic. Wait until available networks appear, which might take two minutes. Tap the carrier that you want.

 

Android: Open the Settings menu >Tap More > Mobile Networks > Carrier and turn off Automatic. Wait until available networks appear, which might take two minutes. Tap the carrier that you want

 

Three networks use 4G in Switzerland can I get you to try one of the following:

 

Sunrise

Salt

Swisscom

 

Did this work?

 

Many thanks,

 

Lee

1 REPLY 1
by
EE Employee
Solution

Re: Why cant I use 4g in Switzerland

Hi @PaulecoW and welcome to the community.

 

So I can try and help, please may I get you to perform a manual network search and choose a network other than what you are on.

 

iPhone: Go to Settings > Carrier and turn off Automatic. Wait until available networks appear, which might take two minutes. Tap the carrier that you want.

 

Android: Open the Settings menu >Tap More > Mobile Networks > Carrier and turn off Automatic. Wait until available networks appear, which might take two minutes. Tap the carrier that you want

 

Three networks use 4G in Switzerland can I get you to try one of the following:

 

Sunrise

Salt

Swisscom

 

Did this work?

 

Many thanks,

 

Lee

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.