by rj59
Visitor

Texting in Russia

I am in Moscow and can make calls to local phones but not send texts. This is costing a fortune, The texts just show as failed.

2 REPLIES 2
by Grand Master
Grand Master

Re: Texting in Russia

@rj59  Have you restarted the device since you got there ?    Have you tried turning off 4G ?  

by
EE Employee

Re: Texting in Russia

Hi @rj59 and welcome to the community.

 

So I can try and help, please may I get you to perform a manual network search and choose a network other than what you are on.

 

iPhone: Go to Settings > Carrier and turn off Automatic. Wait until available networks appear, which might take two minutes. Tap the carrier that you want.

 

Android: Open the Settings menu >Tap More > Mobile Networks > Carrier and turn off Automatic. Wait until available networks appear, which might take two minutes. Tap the carrier that you want

 

Are you using the correct Russian dialling code?

 

Did this work?

 

Many thanks,

 

Lee

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.