by Donghan


Hi, I am Donghan Shin. I have a question. I’m in Italy now for travel. But I did not text to 150. How can I roaming in Italy now?

by Ace Contributor
Ace Contributor

Re: Roaming

Hi @Donghan 


Can you try this...

If you log into MyEE and go to Manage device, make sure you have activated roaming and international calls.

Or If you have the MyEE app, go to usage controls, activate use phone abroad and make international and premium calls


If that doesn't work, try a manual network search.


Let us know how it goes!

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.