by AnujVarma
Explorer

Roaming not working in Switzerland

Roaming doesn't work in Switzerland using EE even though roaming services are enabled on my subscription. Please help.

3 REPLIES 3
by Grand Master
Grand Master

Re: Roaming not working in Switzerland

@AnujVarma    Do you have a signal showing on the device? If you do have you enabled within your EE account call abroad and premium rate numbers ?  

by AnujVarma
Explorer

Re: Roaming not working in Switzerland

Unfortunately it is not registering with any of the local network providers. I have a corporate mobile connection so I assume it cannot be any credit issue.

Get Outlook for iOS
by
EE Community Support Team

Re: Roaming not working in Switzerland

Hi there @AnujVarma

 

Welcome to the community.

 

Have you tried connecting to a different network on your phone as below;

 

  • iPhone – Settings > Mobile Data > Network Selection > Turn off Automatic 
  • Android – Settings > More Networks > Mobile Networks > Network Operators > Tap OK 
  • Windows – Settings > Mobile Network > Network Selection > Tap on start manual search

 

Does this work for you?

 

Leanne 🙂

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.

Recent solutions