Highlighted
by mattinlondon Investigator
Investigator

Roaming in Iceland

I am yet another EE customer who is unable to roam in Iceland. It would appear that many users are having this problem. All of the previous topics are marked as 'solved' but no solution is provided. I am a pay as you go customer. I am able to roam in other EU countries. I was successfully roaming in Finland but when I landed in Iceland I cannot connect to any of the available networks, either automatically or by selecting them in settings, despite having a signal. EE seems to have not provided a clear solution to this despite many customers asking over the years.

1 SOLUTION

Accepted Solutions
by mattinlondon Investigator
Investigator
Solution

Re: Roaming in Iceland

SOLUTION:

 

I called EE and was transferred to the technical support team. They reset the network settings on their end and I am now connected to H+. They tried many other things including sending new API settings to my phone but none of these worked.

 

So, to all those who are having problems connecting in Iceland, it would seem your only solution is to call EE tech support and ask them to reset/refresh the network settings for your account on their end. This is not a problem with the device, but with the EE network. This fix involved turning off my phone, waiting for 2 minutes until the tech could do the work on their end, and then it took 2-3 minutes after restart  for my phone to pick up the local network successfully.

7 REPLIES 7
by Grand Master
Grand Master

Re: Roaming in Iceland

Hi @mattinlondon

 

What device do you have?

 

If an iPhone try resetting your network settings.

 

Thanks




To contact EE Customer Services dial 150 From your EE mobile or 07953 966 250 from any other phone.

EE standard opening hours are 8am to 9pm weekday, 8am to 8pm on weekends.
by mattinlondon Investigator
Investigator

Re: Roaming in Iceland

Hi, thanks for your reply. I have a Galaxy S9 with the most recent version of Android. I have tried resetting the phone and also manually connecting to each of the available networks here in Iceland but it still shows that little 'R' on the status bar next to the signal strength. I am able to make calls (I tried calling EE customer service but it is closed) but not use data roaming. Data roaming is turned on in the network settings. As I mentioned, I was roaming in Finland, took off from there, and when I landed here in Iceland it wouldn't connect. When I landed I received a text from EE telling me that I am able to use the service in Iceland as in the UK.

Android will allow you to scan for all available networks and choose the one you want to connect to. I have 3 listed, Vodaphone, Siminn, and Nova IS. I can manually connect to both Vodaphone and Nova IS but not access the internet. 

by
EE Community Support Team

Re: Roaming in Iceland

Hi @mattinlondon.

 

I hope you're having a brilliant time in Iceland so far despite this problem with your phone.

 

I notice you mentioned you're able to make calls. This indicates that your SIM is definitely set up for roaming and international calling (as backed up by you being able to use it in other countries).

 

Is the issue just with mobile data? What happens if you turn 4G off?

 

Do you have a remaining data allowance?

 

Look forward to hearing from you.

 

Chris

by mattinlondon Investigator
Investigator

Re: Roaming in Iceland

Hi Christopher, thanks for looking into this. I have lots of data left. Switching to '3G only' doesn't solve the problem. I noticed that when I switch networks by manually registering to one of the 3 options or switch to the local network by choosing 'select automatically' under Network Operators, it does show the 4G symbol for a few seconds, and then this goes away. Right now I have 3 bars of strength, and the little R showing next to that. In Finland and in other countries, the R for roaming goes away and the phone shows a 4G symbol when it connects to the local network.

 

I am currently registered on Vodaphone with LTE,3G,2G enabled, roaming enabled, but the data still does not work.

by Grand Master
Grand Master

Re: Roaming in Iceland

@mattinlondon Can I just ask have you tried just turning off and then back on since you got there.  

by mattinlondon Investigator
Investigator
Solution

Re: Roaming in Iceland

SOLUTION:

 

I called EE and was transferred to the technical support team. They reset the network settings on their end and I am now connected to H+. They tried many other things including sending new API settings to my phone but none of these worked.

 

So, to all those who are having problems connecting in Iceland, it would seem your only solution is to call EE tech support and ask them to reset/refresh the network settings for your account on their end. This is not a problem with the device, but with the EE network. This fix involved turning off my phone, waiting for 2 minutes until the tech could do the work on their end, and then it took 2-3 minutes after restart  for my phone to pick up the local network successfully.

by
EE Community Support Team

Re: Roaming in Iceland

I'm delighted to see that you're able to connect now, @mattinlondon.

 

As a thank you for sharing your solution, I'd love to send you a small gift from the EE Community team. 🙂

 

Spot prize.jpg

 

I've sent you a private message to get some more information from you.

 

Thanks again.


Chris

Let's get started

Join the EE Community to ask, answer, learn and share.