by DavidAH
Explorer

Restricted international calls

My international calls are restricted even though I have 180 minutes of Intl calls on my contract, US included which is where I am right now, I can't even call customer services. How am I supposed to get this fixed if I can't even speak to a human down the phone?

5 REPLIES 5
by Grand Master
Grand Master

Re: Restricted international calls

Hi, 

 

If you want to speak to CS then try using a landline. Or If you cannot call EE and you are a pay monthly customer you can use EE live chat, available via your online account or via EE contract page here (click on the cross next to EE and the live chat function will be visible) 

 

Thanks 




To contact EE Customer Services dial 150 From your EE mobile or 07953 966 250 from any other phone.

EE standard opening hours are 8am to 9pm weekday, 8am to 8pm on weekends.
by Brilliant Contributor
Brilliant Contributor

Re: Restricted international calls

@DavidAH You may be able to activate roaming yourself by logging into your my Ee then manage device and then device usage controls. If not and you are a personal pay monthly customer you need to follow @Northerner advice 

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Star" button below.
by
EE Employee

Re: Restricted international calls

Hi @DavidAH and welcome to the community.

 

So I can try and help, please may I get you to perform a manual network search and choose a network other than what you are on.

 

Please also can I get you to try and dial a friend or family member using format of 00447*********, did this work?

 

Also, please let me know If you are using an EE personal or business account as I may be able to assist with our live chat service?

 

Many thanks,

 

Lee

by DavidAH
Explorer

Re: Restricted international calls

Hi @Lee_H,

 

I tried both methods, they didn't work. I'm on a Business contract.

 

I managed to find that calling from abroad is blocked in my settings, I've tried changing this several times and it won't let me, it keeps giving me the response of "Sorry something went wrong. We've not been able to update the usage controls. Please try again later."

 

Thanks

 
by
EE Community Support Team

Re: Restricted international calls

Hi @DavidAH

 

Thank you for taking the time to reply to @Lee_H

 

Please see our Roaming with EE - What to do if you're having problems abroad support article for some additional hints, tips and tricks to activate your services.

 

If non of these work, then you will need to please call business customer services either via a landline or alternative mobile phone.

 

Thanks

 

Richard

 

🙂

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.