by Nic100 Investigator
Investigator

No network coverage in USA

It just says No Service constantly at the top. Data Roaming is on, Travel Pass activated. I've manually searched for networks which I find but they don't connect. I can see this problem on a few previous threads but I'm unsure of the solution. I'm unable to call EE as I have no coverage. 

 

PS I noticed a network appear fir about 5 minutes then it disappeared again!

5 REPLIES 5
by
EE Community Support Team

Re: No network coverage in USA

Hello there @Nic100

 

Thanks for coming to the community.

 

Have you used the device abroad previously?

 

Also have you received any welcome texts from us at all since you got there?

 

Speak soon 🙂

 

 

by Nic100 Investigator
Investigator

Re: No network coverage in USA

Hi @Leanne_T, thanks for getting back. Yeach I used it in the US last year and a couple of times in Europe this year. I only received the welcome texts a few days into my holiday when I had network coverage for 5 minutes. Then nothing again. 

 

Update - I used a workaround given by @Cochi which seems to have worked (deactivate 4G, manually set to T-Mobile, airplane mode for 10 secs). I do however think there is currently an issue with network coverage in the California area judging by current posts & the fact that my partner is having the exact same problem when his has also worked fine previously

by
EE Community Support Team

Re: No network coverage in USA

Thank you for trying this @Nic100

 

Have you both connected to a network now?

 

Thanks, Leanne.

by Nic100 Investigator
Investigator

Re: No network coverage in USA

Hi @Leanne_T yes we've both connected to T-Mobile using the workaround. 

by
EE Community Support Team

Re: No network coverage in USA

Thanks for letting me know @Nic100

 

Hope you have an amazing time 🙂

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.