by Farida9 Investigator
Investigator

NO signal in Italy

hi there, 
I travel to Italy very often, always with the same mobie/plan and I have never had issues at all. When I arrived I had no troubles but the day after I have completely lost the signal. I cannot make/receive calls and obviously no internet. 
I cannot even contact 150. What shall I do? 

1 SOLUTION

Accepted Solutions
by Ace Contributor
Ace Contributor
Solution

Re: NO signal in Italy

Hi @Farida9 Sounds more like a handset problem. Is roaming enabled and have you tried turning powering it off and on again?

6 REPLIES 6
by Ace Contributor
Ace Contributor

Re: NO signal in Italy

Hi @Farida9 Have you made any changes to your plan recently?

 

Have you tried a manual network search? what happens when you select a network?

by Farida9 Investigator
Investigator

Re: NO signal in Italy

The only unusual thing is that before going to Italy I spent a couple of days in Switzerland but there I had no problems at all. 

It says "Error while searching for networks" 

by Ace Contributor
Ace Contributor
Solution

Re: NO signal in Italy

Hi @Farida9 Sounds more like a handset problem. Is roaming enabled and have you tried turning powering it off and on again?

by Farida9 Investigator
Investigator

Re: NO signal in Italy

Yes roaming was enabled. I have just tried to turn it off and on again and it worked !!!!! Thank you for the suggestion 

by
EE Community Support Team

Re: NO signal in Italy

Good Morning @Farida9.

 

Welcome to the community 🙂

 

I'm glad you're all sorted following @chistery's advice!

 

I hope you have a great time in Italy.

 

Jon

by Ace Contributor
Ace Contributor

Re: NO signal in Italy

@Jon_K beat me too it, what he said! Robot Happy

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.