by Viki913 Valued Contributor
Valued Contributor

My free EU roaming is not working

Hi guys, 

 

I have a big problem, I'm currently in Hungary (EU), I sent a ROAMING message to 150, which said my phone is already set up to use abroad, just need to restart when the roaming is on. When the plane landed, I switched my phone on/off/on, tried everything, but it still says "no service", while everyone else was able to use their phone.

I'm going to be away for 3 weeks, and I'll pay for my contract, which I won't be able to use? What can I do? Please help me

Viktoria

1 REPLY 1
by
EE Community Support Team

Re: My free EU roaming is not working

Hi @Viki913

 

Thanks for dropping by the community.

 

As you checked roaming is set up, your phone should be able to connect.

 

Could you try the below steps and get back to me with the results?

 

Try re-booting your device

 

Try turning 4G off in ‘settings’

 

Do a manual network search in ‘settings’:-

  • iPhone – Settings > Carrier > Toggle Automatic OFF

  • Android – Settings > More Networks > Mobile Networks > Network Operators > Tap OK

  • Windows – Settings > Mobile Network > Network Selection > Tap on start manual search

You can see more help on our What to do if you're having problems abroad supporting article.

 

Please let me know how you get on.

 

Chris 🙂

 

 

 

 

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.