by Katyboo84 Investigator
Investigator

My USA roaming isn’t working on my EE Max Plan

I have two separate EE Max Plans one for me, one for my wife (both purchased the same day, both

on the same account). We landed in the USA and both got the same text “

Hi from EE. Just a reminder that while you're in The United States of America you can use your plan minutes, texts and data allowances at no extra cost.“

 

My wife’s plan works and she’s been roaming for 6 days here, whereas I haven’t been able to roam and shortly afterwards got a text instructing me to buy a roaming add on. 

 

I can’t get through to customer services because of the time

difference and every time I’ve tried they’re either closed or they are REALLY busy and I don’t want to spend

my holiday on hold for over 30 mins!!! 

 

What can I do!

 

7 REPLIES 7
by Andrewworr Established Contributor
Established Contributor

Re: My USA roaming isn’t working on my EE Max Plan

Hi there @Katyboo84, welcome to the EE Community.

 

I'm really sorry to hear of this issue you are having. I know how frustrating these things can be, especially as you're on holiday, but don't worry as the good folk here at the EE Community will try to put things right!

 

Firstly can I please ask you to power off the phone and remove your SIM card in your phone? Whilst you might not have a SIM removal tool at hand since you're on holiday, if you can access a paperclip this should still do the trick. Oh, and if you're using a phone that doesn't require a SIM removal tool to access the SIM card, then ignore the bit about using a SIM removal tool / paperclip. 🙂


Secondly, I'd like to ask you to insert the SIM card again after about 5 minutes of removing it. Please ensure it's gone in properly.

 

Thirdly, please turn the phone back after inserting the SIM again.

 

Fourhtly, please check the settings in your phone settings - is the date and timezone correct to where you are? Have you got location enabled? Please make sure the answers to these questions are "yes" and "yes". 🙂

 

I really hope these steps help to fix the issue you're having and I apologize you haven't received a reply sooner since you posted this yesterday. If this hasn't helped, definitely reply and I or another community member will try to help further!

 

I hope you have a great holiday. 🙂

 

Andrew

by
EE Community Support Team

Re: My USA roaming isn’t working on my EE Max Plan

Hi @Katyboo84,

 

Thanks for joining the EE Community.

 

I'm sorry to hear you are having problems using your phone in the USA.

 

Did restarting your phone resolve the issue?

 

James

by Katyboo84 Investigator
Investigator

Re: My USA roaming isn’t working on my EE Max Plan

No restarting my phone did not resolve the problem @James_B

by Katyboo84 Investigator
Investigator

Re: My USA roaming isn’t working on my EE Max Plan

Hi there, this didn’t fix the problem

Sent from my iPhone
by
EE Community Support Team

Re: My USA roaming isn’t working on my EE Max Plan

Hi @Katyboo84,

 

What happens if you try to load a page in your web browser?

 

Are you redirected to the add-ons page?

 

Thanks

 

James

by Katyboo84 Investigator
Investigator

Re: My USA roaming isn’t working on my EE Max Plan

Yep I get this add on page. Tried the advice on here to turn the phone off and take the sim out too, didn’t work! The settings show in time and date the right time zone etc and the add on page says welcome to the USA  

by
EE Community Support Team

Re: My USA roaming isn’t working on my EE Max Plan

Hi @Katyboo84

 

Thanks for trying that. I've sent you a private message to get some more information from you.

 

Please have a look and get back to me.

 

Chris

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.