by Seandan
New Member

Just arrived in Portugal and no signal on my contract phone

 
2 REPLIES 2
by Grand Master
Grand Master

Re: Just arrived in Portugal and no signal on my contract phone

@Seandan   Login to your EE online account and enable roaming it’s under manage this device,  you’ll also need to enable call abroad and premium rate numbers.  Then reset the device.  

by
EE Community Support Team

Re: Just arrived in Portugal and no signal on my contract phone

Good Evening @Seandan

 

Thanks for posting on the community.

 

If you can follow the advice from @Chris_B and activate roaming and calls abroad if they are not showing as ticked.

 

If they are ticked, can you try and connect to a different network as below;

 

  • iPhone – Settings > Mobile Data > Network Selection > Turn off Automatic
  •  Android – Settings > More Networks > Mobile Networks > Network Operators > Tap OK 
  • Windows – Settings > Mobile Network > Network Selection > Tap on start manual search

 

Let us know how you get on 🙂

 

Leanne.

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.