by JohnnyF
Explorer

In Cyprus- I get the ‘your service doesn’t allow’ message. ?

 
1 SOLUTION

Accepted Solutions
by Grand Master
Grand Master
Solution

Re: In Cyprus- I get the ‘your service doesn’t allow’ message. ?

Hi @JohnnyF 

 

Log into your on line account and then Menu - Manage Device - make sure you have activated roaming and international calls.
Or
From the MyEE app Current Usage - Controls - activate use phone abroad and make international and premium calls

 

If you are roaming in the North or near the border you might connect to Turkey network which is outside your EU allowance. Costs for roaming in the North can be found here.


Thanks




To contact EE Customer Services dial 150 From your EE mobile or 07953 966 250 from any other phone.

EE standard opening hours are 8am to 9pm weekday, 8am to 8pm on weekends.
2 REPLIES 2
by Grand Master
Grand Master
Solution

Re: In Cyprus- I get the ‘your service doesn’t allow’ message. ?

Hi @JohnnyF 

 

Log into your on line account and then Menu - Manage Device - make sure you have activated roaming and international calls.
Or
From the MyEE app Current Usage - Controls - activate use phone abroad and make international and premium calls

 

If you are roaming in the North or near the border you might connect to Turkey network which is outside your EU allowance. Costs for roaming in the North can be found here.


Thanks




To contact EE Customer Services dial 150 From your EE mobile or 07953 966 250 from any other phone.

EE standard opening hours are 8am to 9pm weekday, 8am to 8pm on weekends.
by JohnnyF
Explorer

Re: In Cyprus- I get the ‘your service doesn’t allow’ message. ?

Thanks!

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.