by Xanny
Visitor

I’ve arrived in Manresa, Spain earlier today and since then I’ve had no internet

Read more
Normally when I travel I always have internet connection and automatic roaming. What changed ? 
2 REPLIES 2
by Grand Master
Grand Master

Re: I’ve arrived in Manresa, Spain earlier today and since then I’ve had no inte

@Xanny 

Have you used this device abroad before?  

Have you restarted the device?

What device is it ?

by
EE Community Support Team

Re: I’ve arrived in Manresa, Spain earlier today and since then I’ve had no inte

Hi @Xanny

 

Welcome to the community, I hope you're having a lovely time in Spain so far. 🙂

 

Could you please log into your My EE account and tap Menu > Manage Device?

 

If it shows that roaming is enabled, please try the troubleshooting below:

 

Device Type Actions
Apple Settings > Carrier > Toggle Automatic OFF
Android Settings > More Networks > Mobile Networks > Network Operators > Tap OK
Windows Settings > Mobile Network > Network Selection > Tap on start manual search

 

 

If it isn't enabled and you're an EE pay monthly customer, you can access our live chat service through your My EE account (on a deskstop browser).

 

A chat pop up will appear when they're available.


Chris

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.