by NajdMJ
New Member

I’m traveling and my iPhone has no service. What can I do?

I am traveling overseas and my iPhone has no service. I usually receive a text message about overseas deals or welcoming messages but I didn’t get any. Also, I tried to restart my phone, take out my SIM card and put it back in, I also restarted my network settings but nothing worked, I still have no service. 

Please help

4 REPLIES 4
by Ace Contributor
Ace Contributor

Re: I’m traveling and my iPhone has no service. What can I do?

Hi @NajdMJ

 

Welcome to the Community,

 

Could you log into your My EE account online

 

Then go to Menu > Manage Device > Roaming and also Call Abroad and Premium Rate > They will need to show as ticked for you to use your phone abroad.

 

If you can activate both settings this will update within 24 hours.

 

alternatively call 00442073620200 from a landline from 8AM tomorrow morning.

 

by Grand Master
Grand Master

Re: I’m traveling and my iPhone has no service. What can I do?

@David: Done!

 

This "General Chat" board should be killed off or at least renamed to something more innocuous like "Off-Topic", "General Banter", "Natter about all things outside EE". I do so hate the presence of this board :(!

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Thumbs Up" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC
by Ace Contributor
Ace Contributor

Re: I’m traveling and my iPhone has no service. What can I do?

@XRaySpeX agree 👍

by
EE Community Support Team

Re: I’m traveling and my iPhone has no service. What can I do?

Hi @NajdMJ

 

Welcome to the community. 🙂

 

As well as following @David's advice, please try the troubleshooting steps below:

 

Try re-booting your device

 

Turn the device off and back on or turn airplane mode off then on.

 

Perform a manual network search:-

 

•    iPhone – Settings > Carrier > Toggle Automatic OFF
•    Android – Settings > More Networks > Mobile Networks > Network Operators > Tap OK
•    Windows – Settings > Mobile Network > Network Selection > Tap on start manual search

 

Please let me know if any of that works.

 

Chris

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.