by Jackievauls70
Visitor

I’m in Greece and it won’t let me make phone calls

 
1 REPLY 1
by
EE Employee

Re: I’m in Greece and it won’t let me make phone calls

Hi @Jackievauls70 and welcome to the community.

 

So I can try and help, please may I get you to perform a manual network search and choose a network other than what you are on.

 

iPhone: Go to Settings > Carrier and turn off Automatic. Wait until available networks appear, which might take two minutes. Tap the carrier that you want.

 

Android: Open the Settings menu >Tap More > Mobile Networks > Carrier and turn off Automatic. Wait until available networks appear, which might take two minutes. Tap the carrier that you want

 

Please, also can I get you to try and dial a friend or family member using the format of 00447********* and try using data. 

 

Did this work?

 

Many thanks,

 

Lee

Let's get started

Join the EE Community to ask, answer, learn and share.