by Guyzee12
Explorer

I have no coverage in malta

Please help.. i have no signal in malta.. roaming is on

4 REPLIES 4
by Ace Contributor
Ace Contributor

Re: I have no coverage in malta

Hi @Guyzee12,

 

Malta seems to having a few issues at the moment

 

Assuming you have roaming enabled on your account and it's worked before abroad, try turning 4G off and doing a manual network search and selecting it that way.

 

If that doesn't work and you've never had roaming working, your account may not be set up to allow it. Check MyEE under Manage My Device. Does it say roaming is on? You may need to contact EE to change it.

 

Let us know how it goes!

by
EE Community Support Team

Re: I have no coverage in malta

community_champion (1).png

Hi @chistery

 

Thanks for taking the time to share helpful information with the community - it's great to have people sharing information that could help others, it's what the community is all about!

 

As a thank you from us, I’d love to treat you to dinner!

 

I'll send you a Private Message to get some additional details.

 

Many thanks,

 

Richard

 

Smiley Happy

by Guyzee12
Explorer

Re: I have no coverage in malta

Yeah tried that... then i clicked go mobile and left it ... took 5 minutes to establish a connection... but then it connected... 

happy now.. thanks

by
EE Community Support Team

Re: I have no coverage in malta

Great news @Guyzee12

 

Thanks for letting us know 🙂

 

Have a great time!

 

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.