by Janesp Investigator
Investigator

I couldn’t get any service while in lanzarote why is this when I’ve had no probl

I went to lanzarote in February and had service. When I went in May, no service and the same in feurteventura why is this?

3 REPLIES 3
by
EE Community Support Team

Re: I couldn’t get any service while in lanzarote why is this when I’ve had no p

Hi there @Janesp

 

Thanks for coming to the community.

 

When you were there did you try a manual network search;

 

  • iPhone – Settings > Carrier > Toggle Automatic OFF

 

  • Android – Settings > More Networks > Mobile Networks > Network Operators > Tap OK

 

  • Windows – Settings > Mobile Network > Network Selection > Tap on start manual search

 

Also, could you receive calls and texts?

 

Leanne 🙂

by Janesp Investigator
Investigator

Re: I couldn’t get any service while in lanzarote why is this when I’ve had no p

It just showed no service I. Top left hand corner of the phone screen. I didn’t know I had to turn automatic of as I didn’t have to do it in February, it just connected to Movistar when I got off the plane and turned it on

by
EE Community Support Team

Re: I couldn’t get any service while in lanzarote why is this when I’ve had no p

Hi @Janesp

 

If your phone shows no service, then a network selection could be needed following the steps provided.

 

Also, if you text ROAMING to 150 this will let you know if your account is set up for roaming.

 

Thanks, Leanne 🙂

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.