by Aaron8
Visitor

I cant call or text in Greece

I cant call or text in Greece. I am on Personal Pay Monthly. I texted ROAMING to 150 and it said I was ready to use it abroad. When I got here I got a text saying I can use all my allowances and on the first day of my holiday it worked just fine but after that I couldnt call or text I am using COSMOTE GR.

2 REPLIES 2
by Grand Master
Grand Master

Re: I cant call or text in Greece

Try logging into your My EE account online & go to Menu / Manage Device / Roaming Abroad and also Call Abroad and Premium rate. They will show as ticked if roaming and calling abroad is activated. If they are not ticked, can you activate these settings?

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Thumbs Up" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC
by
EE Community Support Team

Re: I cant call or text in Greece

Afternoon @Aaron8

 

Thanks for coming to the community.

 

Has the advice from @XRaySpeX helped get your phone working in Greece?

 

If not, can you try and connect to a different network as below;

 

  • iPhone – Settings > Mobile Data > Network Selection > Turn off Automatic
  • Android – Settings > More Networks > Mobile Networks > Network Operators > Tap OK 
  • Windows – Settings > Mobile Network > Network Selection > Tap on start manual search

 

Let us know how you are getting on 🙂

 

Leanne.

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.