by Kellieberry
Explorer

I arrived on holiday in Malta last night And have no coverage whatsoever.

I arrived on holiday in Malta last night And have no coverage whatsoever. I can use wifi but simply have no service at all 😞

4 REPLIES 4
by Ace Contributor
Ace Contributor

Re: I arrived on holiday in Malta last night And have no coverage whatsoever.

Did you enable roaming before you left, @Kellieberry

 

Have a read of this helpful page:

 

https://community.ee.co.uk/t5/Roaming/Roaming-with-EE-What-to-do-if-you-re-having-problems-abroad/td...

by Kellieberry
Explorer

Re: I arrived on holiday in Malta last night And have no coverage whatsoever.

No but I come o Malta every year and have never had to enable anythung before - usually it's automatic but now it just says no service. 

by Ace Contributor
Ace Contributor

Re: I arrived on holiday in Malta last night And have no coverage whatsoever.

@Kellieberry A lot of people reported issues with Malta recently. Try turning off 4G and doing a manual network search.

by
EE Community Support Team

Re: I arrived on holiday in Malta last night And have no coverage whatsoever.

Hi @Kellieberry

 

Thanks for dropping by community, I hope you're having a lovely time so far despite this. 🙂

 

Did you follow the brilliant instructions from @chistery above?

 

If you still can't find a connection, you can activate roaming on your My EE account through your browser.

 

If this doesn't work, please contact our customer services from an alternative phone. They'll be able to help you.

 

Let me know how you get on.

 

Chris

 

Let's get started

Join the EE Community to ask, answer, learn and share.