by EleniKoutis
Visitor

I am abroad and all calls and texts are Blocked

 
2 REPLIES 2
by Grand Master
Grand Master

Re: I am abroad and all calls and texts are Blocked

@EleniKoutis  Login to your online account and enable international and premium rate numbers. 

by
EE Community Support Team

Re: I am abroad and all calls and texts are Blocked

Hi @EleniKoutis,

 

Welcome to the EE Community.

 

Were you able to activate your roaming services in My EE?

 

You can find them by selecting 'Manage device' from the menu.

 

Thanks

 

James

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.