by Emlynw Investigator
Investigator

EE will not to the Flow network in the Caribbean

When in Grenada in the Caribbean all outgong calls/texts are barred rendering the phone useless. I have spoken to EE on my return and they have no idea why this is the case and nor did they apear to want to help to resolve the situation.

1 SOLUTION

Accepted Solutions
by
EE Employee
Solution

Re: EE will not to the Flow network in the Caribbean

Hi @Emlynw and welcome to the community.

 

We only partner with Digicell in Grenada, this is why you have experienced an issue while trying to connect to Flow.

 

Many thanks,

 

Lee

5 REPLIES 5
by Grand Master
Grand Master

Re: EE will not to the Flow network in the Caribbean

@Emlynw Did you enable roaming on your account before you left the UK ?  If you did it or it was enabled where you putting 44 or +44 instead of the 0 at the start of the number?   

by Emlynw Investigator
Investigator

Re: EE will not to the Flow network in the Caribbean

Yes everything was set ready to go. I have been to the Caribbean on many occasions when I have successfully to the Digicell network. Clearly the 'Flow' network does not link with EE.  

by
EE Employee
Solution

Re: EE will not to the Flow network in the Caribbean

Hi @Emlynw and welcome to the community.

 

We only partner with Digicell in Grenada, this is why you have experienced an issue while trying to connect to Flow.

 

Many thanks,

 

Lee

by Emlynw Investigator
Investigator

Re: EE will not to the Flow network in the Caribbean

If EE only partner Digicell in Grenada how do I find it ? My phone defaulted to 'Flow' so are you telling me that EE phones are now useless in Grenada ? Why don't EE have a relationship with Flow which I believe it is part of the C&W company ?  

by
EE Employee

Re: EE will not to the Flow network in the Caribbean

Hi @Emlynw

 

You are able to manual network search and choose another network available.

 

iPhone: Go to Settings > Carrier and turn off Automatic. Wait until available networks appear, which might take two minutes. Tap the carrier that you want.

 

Android: Open the Settings menu >Tap More > Mobile Networks > Carrier and turn off Automatic. Wait until available networks appear, which might take two minutes. Tap the carrier that you want

 

I would also advise on turning of 4G connectivity as this will assist in connecting to the local networks.

 

Many thanks,

 

Lee

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.