by tharper97
Explorer

Cyprus roaming

Hi. I’m currently in Cyprus and unable to make any calls on two different iPhones (6s).

roaming is set to on and they were working at the start of the holiday. 

Dial assist is switched on. I’ve tried turning that off and manually entering the number putting the internationaldialling codes in instead but it makes no difference. I have three bars with MTN.

Anyone got any ideas.

 

Many Thanks. 

 

Tam

1 SOLUTION

Accepted Solutions
by Brilliant Contributor
Brilliant Contributor
Solution

Re: Cyprus roaming

Hello @tharper97

 

Thank you for posting on the Community today. Smiley Happy

 

I hope you're having a lovely time in Cyprus, it's one of my favourite places to visit. Smiley Happy

 

I travel to Cyprus at least once a year and I sometimes face the same problems you are currently experiencing. I usually manually roam onto Cyta-Voda and that normally fixes any problems that was occurring.

 

You can manually select a network by going to Settings > Mobile > Toggle the "Automatic" Slider to Off > Select Cyta-Voda.

 

I hope this helps. Smiley Very Happy

3 REPLIES 3
by
EE Community Support Team

Re: Cyprus roaming

Hi @tharper97,

 

Welcome to the EE Community.

 

What happens when you try to make a call?

 

Do you hear a recorded message?

 

Are you able to receive calls?

 

Thanks

 

James

by Brilliant Contributor
Brilliant Contributor
Solution

Re: Cyprus roaming

Hello @tharper97

 

Thank you for posting on the Community today. Smiley Happy

 

I hope you're having a lovely time in Cyprus, it's one of my favourite places to visit. Smiley Happy

 

I travel to Cyprus at least once a year and I sometimes face the same problems you are currently experiencing. I usually manually roam onto Cyta-Voda and that normally fixes any problems that was occurring.

 

You can manually select a network by going to Settings > Mobile > Toggle the "Automatic" Slider to Off > Select Cyta-Voda.

 

I hope this helps. Smiley Very Happy

by tharper97
Explorer

Re: Cyprus roaming

Hi. Yes. Spent some time on live chat with ee and this was the fix. MTN was the automatic selection for a provider here and changing it over manually to one of the other available ones resolved it. Many thanks for taking the time to post. 

 

Cheers. 

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.