by chriselcombe Investigator
Investigator

Calls in USA

I've arrived in the US and have no network coverage. I've tried turning data roaming on but nothing shows up. Network selection is turned on to automatic.

 

I didn't text Roaming to 150 before I came and now, there seems to be no way to do so, without a mobile signal! Can you help?

 

Thanks

6 REPLIES 6
by Grand Master
Grand Master

Re: Calls in USA

If you are on contract, try logging into your MyEE account online & go to Menu / Manage Device / Roaming Abroad and also Call Abroad and Premium rate. They will show as ticked if roaming and calling abroad is activated. If they are not ticked, can you activate these settings?

PAYG is auto enabled for roaming. You don't need to & can't do any of the above.

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Thumbs Up" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC
by
EE Community Support Team

Re: Calls in USA

Hi @chriselcombe 

 

Thanks for posting 🙂

 

Can you try the steps @XRaySpeX has provided and let us know if this works for you?

 

Hope you are having a great time 🙂

 

Leanne.

by chriselcombe Investigator
Investigator

Re: Calls in USA

Hi Leanne, 

I tried these steps but roaming and calling from abroad were already ticked as active. Can you suggest anything else?

Chris

by
EE Community Support Team

Re: Calls in USA

Hi @chriselcombe

 

Thanks for trying this for me.

 

Can you try these steps below;

 

  • Try a re-start on your device

 

 

  • iPhone – Settings > Mobile Data > Network Selection > Turn off Automatic
  •  Android – Settings > More Networks > Mobile Networks > Network Operators > Tap OK
  •  Windows – Settings > Mobile Network > Network Selection > Tap on start manual search

 

 

Let me know how this goes 🙂

 

Leanne.

by chriselcombe Investigator
Investigator

Re: Calls in USA

Hi Leanne

I woke up this morning with network, before I needed to try your suggestion. Maybe it just took 24 hours for it to be activated? Anyway, hopefully that will be it sorted now. Thanks for your help.

Chris

by
EE Community Support Team

Re: Calls in USA

Great news @chriselcombe

 

Thanks for coming back and letting me know 🙂

 

Have a brilliant time.

 

Leanne.

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.