by CATHIE4
Visitor

Blocked calls

I took an add on to cover my on holiday in Canada I can text home and receive but my calls out and in are blocked I have a Samsung s7 android 

2 REPLIES 2
by Grand Master
Grand Master

Re: Blocked calls

If on contract, did you activate roaming on your EE a/c before you left UK?

 

Often just rebooting the phone is the simple remedy. Otherwise try logging into your My EE account online & go to Menu / Manage Device / Roaming Abroad and also Call Abroad and Premium rate. They will show as ticked if roaming and calling abroad is activated. If they are not ticked, can you activate these settings?

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Thumbs Up" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC
by
EE Community Support Team

Re: Blocked calls

Hi @CATHIE4.

 

Welcome to the community.

 

I hope you're having a great time in Canada 🙂

 

Let us know if roaming and international calls are activated in your My EE Account as @XRaySpeX has suggested.

 

Is there anyone else with you who's using an EE phone?

 

Jon

 

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.