by Jomakel Investigator
Investigator

Cannot make calls from greece

Keep trying to change settings to make calls abroad but no luck

6 REPLIES 6
by Grand Master
Grand Master

Re: Cannot make calls from greece

Hi @Jomakel 

 

Did you activate roaming?

 

Log into your on line account and then Menu - Manage Device - make sure you have activated roaming and international calls.
Or
From the MyEE app Current Usage - Controls - activate use phone abroad and make international and premium calls

Thanks




To contact EE Customer Services dial 150 From your EE mobile or 07953 966 250 from any other phone.

EE standard opening hours are 8am to 9pm weekday, 8am to 8pm on weekends.
by Jomakel Investigator
Investigator

Re: Cannot make calls from greece

Already tried this but no luck thanks anyway

by Grand Master
Grand Master

Re: Cannot make calls from greece

Hi @Jomakel 

 

Are you on PAYG?

 

If you are on pay monthly contract, and my above post doesn't work then you will need to speak to EE CS. Use live chat via your online account. 

 

Thanks




To contact EE Customer Services dial 150 From your EE mobile or 07953 966 250 from any other phone.

EE standard opening hours are 8am to 9pm weekday, 8am to 8pm on weekends.
by
EE Community Support Team

Re: Cannot make calls from greece

Hi @Jomakel


Welcome to the community, I hope you're having an amazing time in Greece so far. 😄

 

Could you try manually connecting to another network please?

 

Device type Actions
iPhone Settings > Mobile Data > Network Selection > Turn off Automatic
Android Settings > More Networks > Mobile Networks > Network Operators > Tap OK
Windows Windows – Settings > Mobile Network > Network Selection > Tap on start manual search

 

Chris

by Jomakel Investigator
Investigator

Re: Cannot make calls from greece

All sorted now thanks 

by
EE Community Support Team

Re: Cannot make calls from greece

Brilliant, @Jomakel

 

Enjoy the rest of your trip. 😄


Chris

Let's get started

Join the EE Community to ask, answer, learn and share.