by flygirl Contributor
Contributor

"Something went wrong" message on Lumia 640 camera app

Hello, I've read everything I can find about this, both here and on microsoft but all to no avail.

I tried using my Lumia Camera app on my Lumia 640 phone and keep getting the message "Sorry, something went wrong" 

I have a Microsoft account. 

I've checked if the system apps are up-to-date. (Go to Store > ... > settings > check for updates).

 

I've tried:

Go to "Settings."
Scroll down to "privacy" and open "app permissions."
Choose "Camera."
Scroll down to "Lumia Camera" and make sure the app is "On."

 

I've also tried:

delete the camera APP and then go to the Store and re-install the APP. Fixed it on both phones. Just make sure you re-install the correct MS Camera APP, it should be the Purple Lumia Camera APP.

 

I've turned off the phone, turned it back on and tried all the above all over again and I'm still getting the same message. I thought I'd try asking here before going to microsoft mobile support. 

I hope someone might be able to help?

Thanks!

 

 

 

 

1 SOLUTION

Accepted Solutions
by flygirl Contributor
Contributor
Solution

Re: "Something went wrong" message on Lumia 640 camera app

Hi Lee, 

Thanks for your reply.

 

I was unable to restore the camera default settings. I tried the other MS camera app, also tried "reset" camera. Ended up calling EE in the hope I could avoid a factory reset. EE suggested remove and replace battery and if no joy then to do exactly what you suggested - and that worked!

 

Sorry for the delay in replying - took a while sorting getting backed up and then setting things up properly after factory reset.

 

I have learned much in the last week!

 

Thanks so much to the people here on EE Community for being so helpful and patient. I'm very grateful :-)

4 REPLIES
by Legend
Legend

Re: "Something went wrong" message on Lumia 640 camera app

Hi, 

 

Have you tried another camera app? 

 

Have you tried reinstalling the OS ? 

 

 

Thanks




To contact EE Customer Services dial 150 From your EE mobile or 07953 966 250 from any other phone.

EE standard opening hours are 8am to 9pm weekday, 8am to 8pm on weekends.
by
EE Employee

Re: "Something went wrong" message on Lumia 640 camera app

Welcome to the Community  @flygirl

 

I can see you have tried the usual of checking for updates, deleting and reinstalling.

 

Please, can you try the following as well

 

  • Restore the default camera settings, go to Settings and then swipe left to applications > photos+camera (pictures+camera). Scroll down to the bottom and tap reset camera.

If that does not resolve, please back up your device and reset to factory settings.

 

If you need any help in doing this please see Lumia 640 Help Pages.

 

Many thanks

 

Lee

 

 

 

 

 

 

 

 

by flygirl Contributor
Contributor

Re: "Something went wrong" message on Lumia 640 camera app

Thanks for your reply. I tried the other MS camera app, also tried "reset" camera. Ended up calling EE who suggested remove and replace battery - that didn't work, so I ended up doing a hard reset. sorry for the delay in replying - took a while setting things up properly after hard reset. 

Thanks

 

Sorry, I should have addressed this to "Northerner"...THANKS Northerner!

by flygirl Contributor
Contributor
Solution

Re: "Something went wrong" message on Lumia 640 camera app

Hi Lee, 

Thanks for your reply.

 

I was unable to restore the camera default settings. I tried the other MS camera app, also tried "reset" camera. Ended up calling EE in the hope I could avoid a factory reset. EE suggested remove and replace battery and if no joy then to do exactly what you suggested - and that worked!

 

Sorry for the delay in replying - took a while sorting getting backed up and then setting things up properly after factory reset.

 

I have learned much in the last week!

 

Thanks so much to the people here on EE Community for being so helpful and patient. I'm very grateful :-)

Let's get started

Join the EE Community to ask, answer, learn and share.