by Graham9 Investigator
Investigator

Is there a problem with the mast near SW19 4SP? Poor 4G signal for past month.

 
12 REPLIES 12
by Ace Contributor
Ace Contributor

Re: Is there a problem with the mast near SW19 4SP? Poor 4G signal for past mont

Hi @Graham9 

 

there are no know issues currently when I checked the network status for your area. But try the following:

 

A few things to try...

Some problems can be sorted on your phone. Try these quick fixes.

1. Turn airplane mode on and off again

2. Restart your device

3. Check you have the latest software

by Grand Master
Grand Master

Re: Is there a problem with the mast near SW19 4SP? Poor 4G signal for past mont

Hi @Graham9 

 

You can check local mast issues, and report problems here.

 

Thanks




To contact EE Customer Services dial 150 From your EE mobile or 07953 966 250 from any other phone.

EE standard opening hours are 8am to 9pm weekday, 8am to 8pm on weekends.
by Graham9 Investigator
Investigator

Re: Is there a problem with the mast near SW19 4SP? Poor 4G signal for past mont

Yes I've tried all those.  My battery has been discharging much faster recently unless I disable 4G.  I've even tried an O2 SIM card - that works well, so I assumed it was a network problem, but no issues show up.

by Grand Master
Grand Master

Re: Is there a problem with the mast near SW19 4SP? Poor 4G signal for past mont

Hi @Graham9 

 

Have you reported the issue via the checker? 

 

Your battery will drain faster if it's trying to obtain a signal resulting from a poor or faulty mast.

 

Thanks




To contact EE Customer Services dial 150 From your EE mobile or 07953 966 250 from any other phone.

EE standard opening hours are 8am to 9pm weekday, 8am to 8pm on weekends.
by Grand Master
Grand Master

Re: Is there a problem with the mast near SW19 4SP? Poor 4G signal for past mont

by Graham9 Investigator
Investigator

Re: Is there a problem with the mast near SW19 4SP? Poor 4G signal for past mont

It is a Samsung Galaxy J3. Samsung checked it out and did not find any problems.

 

by
EE Community Support Team

Re: Is there a problem with the mast near SW19 4SP? Poor 4G signal for past mont

Good Morning @Graham9

 

Have you been able to try your EE SIM in another device?

 

Does the issue continue?

 

Speak soon, 

 

Katie 🙂

by Graham9 Investigator
Investigator

Re: Is there a problem with the mast near SW19 4SP? Poor 4G signal for past mont

Yes the battery is still discharging rapidly on 4G.  I have not got another suitable phone to try at the minute.

by
EE Community Team

Re: Is there a problem with the mast near SW19 4SP? Poor 4G signal for past mont

Hi @graham,

 

Is the issue now that the phone will not hold any charge?

 

You have advised that it is running low very quickly on 4G, do you have a 4G signal now in your postcode area?

 

If you are still experiencing an issue with the signal, our Tech Gurus will be able to help you further reporting the issue. If this still is the case, you battery will be draining much faster as your phone is constantly looking for a signal to pick up.

 

If you are able to connect to a 4G signal now and you battery is still draining, you can run a quick question and answer session on our Fix My Device tool. This will let you know how you can improve your battery life on the phone before you get in touch with out team.

 

 

Alex 🙂

 

 

by Graham9 Investigator
Investigator

Re: Is there a problem with the mast near SW19 4SP? Poor 4G signal for past mont

The problem seems to be with my phone and EE over the past month.

The SIM card works OK on a different phone and my phone works OK with an O2 SIM card.

I have tried most of the suggestions for improving battery life.

It does not make any sense to me.

by
EE Community Team

Re: Is there a problem with the mast near SW19 4SP? Poor 4G signal for past mont

Hi @Graham9,

 

Thanks for getting back to me 🙂

 

I would suggest talking to our Tech Gururs. They will be here to help from 8am today. They will be able to view your account and get to the bottom of where the issue lies.

 

Please come back et us know how you get on once you've spoken to them.

 

 

Alex 🙂

by Graham9 Investigator
Investigator

Re: Is there a problem with the mast near SW19 4SP? Poor 4G signal for past mont

Sorry to say I have not had much luck.  Nobody seems to know why my EE 4G connection suddenly started draining my battery rapidly.  In the end I have moved to the O2 network which seems to have solved the problem.

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.

Recent solutions