by DontBlameMe Established Contributor
Established Contributor

Using My EE on different PCs at the same time....

Has anyone found this chuffing great big issue with My EE, if you have more than one MyEE account.

 

Simply put I can see the other account info at times when MORE THAN ONE EE account is /has been in use on the same network, has anyone else seen this?

 

There are two scenarios,

 

First I found on an old XP Box with Firefox (Noscript). I logged in with the User account for ONE of my sims, realised I couldn't see the Billing info, so logged out. Logged back in in with the Bill Payers  and still coudn't see the bill !

 

After messing about for some time realised that despite putting the credentials in for the Bill Payers acount, I was actually looking at the Sim account! 

 

Left that session on the screen and powerd up the w10pro laptop (latest Firefox and noscript) and logged in using the Bill Payers account.... and saw the Bill payers details.

 

But every so often I'd get logged out despite still actively using it..... OR errors of the "Unable to login..." type when I was navigating around the logged in session.

 

The other PC was still showing the SIM account, until I tried to use it and it logged me out.

 

I then logged back in on the W10 laptop with Bill Payers account, and AOK.  I then logged back in with the SIM account on the XP PC and simultaneously back on the W10 Laptop opened the bill.

 

After a few moments, both session refeshed, and on the XP PC the Bill Payers account appeared DESPITE ME LOGGING IN WITH THE SIM CREDENTIALS!

 

Can anyone try and replicate this and see if they get the same kinds of "cross talk" ?

 

I use an EE Huawei LTE cube, wired to a POE Ethernet hub, that is wired to the XP box, The W10 Laptop is using WIFI.

 

So I think there are possibly two technical issues here AND A MASSIVE ONE FOR DATA PRTECTION.

 

Just wondering Is "My EE" using the MAC of the Router to keep track of My EE sessions, and why when I log out of one account (and don't close your browser/delete session cookies?) does it insist on ignoring what you enter for the account details and display the previous sessions account!

 

 

Who tests this, and do they do NON-functional testing.

 

DBM, (ex IBM non-functional test consultant)

 

6 REPLIES 6
by Grand Master
Grand Master

Re: Using My EE on different PCs at the same time....


@DontBlameMe wrote:

Just wondering Is "My EE" using the MAC of the Router to keep track of My EE sessions


No way!

 

You could have cookie confusion on a single PC but even that is taken care of by the browser. You are able to switch from 1 MyEE a/c to another by entering the right email username overwriting the previous 1 the cookie remembered from last session.

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Thumbs Up" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC
by
EE Community Support Team

Re: Using My EE on different PCs at the same time....

Hello @DontBlameMe

 

Thanks for coming here.

 

Are both numbers on the same account?

 

If you go into one of the My EE accounts online and then Menu, does this show as a single user account?

 

Leanne.

by DontBlameMe Established Contributor
Established Contributor

Re: Using My EE on different PCs at the same time....

@XRaySpeX

 

Thanks for your reply. Yes I'd have thought it would do something similar re logging out/back in. When I get a moment I'll retry this and be a tad more forensic. My systems are pretty much locked down and what with Noscript.... 

 

This is my second attempt to post a reply as I got the following error from this EE community site:

 

EECommunity.PNG

 

The sites page seemed to "jump" and then keept repeating every 10 seconds or so.... Looks like it may be my in my settings?

 

Thnx again.

by
EE Community Support Team

Re: Using My EE on different PCs at the same time....

Hi @DontBlameMe

 

Can you try clearing all cookies and cache.

 

Also, can you try another browser and see if this happens.

 

Let us know how you get on.

 

Leanne.

by DontBlameMe Established Contributor
Established Contributor

Re: Using My EE on different PCs at the same time....

Hi @Leanne_T

 

Thank you, for your replies.   Can't check at the moment if they are linked at the moment, will do later. However I don't recall seeing anything that susggests they (logins) are linked

 

I have different email addresses for each of them, the Primary Mob number (I have 5) is the same for  the "Bill Payer" and the "SIM" logins.

 

Thanks for the suggestions re cache cookies browser etc,  Already worked out my test coverage matrix to also include a couple of Linux systems even an Android phone (4g and Wifi) if I can reproduce the same symptoms again! Smiley Wink

 

Should get to do it some time this weekend. 

 

Thnx again. DBM

by
EE Community Support Team

Re: Using My EE on different PCs at the same time....

No problem @DontBlameMe

 

Let us know how you get on 🙂

 

Leanne.

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.