by abotsford Investigator
Investigator

Phone is showing unknown device in My EE despite SIM being on a SIM only monthly

I have 3 phones on my account each with 3 SIM only monthly plans, 2 SIM's detect the device correctly but the 3rd SIM doesn't. Phone is showing unknown device in My EE despite SIM being on a SIM only monthly. Moving the SIM between phones that have been detected correctly then shows unkown device on the 3rd SIM. It appears for some reason the 3rd SIM in provisioned differently to the other 2 depsite them all being SIM only monthly accounts. Have tried  tried EE on 150 but get nowhere with the tech team.

Can any of the EE experts or moderators help?

6 REPLIES 6
by Profile closed
Not applicable

Re: Phone is showing unknown device in My EE despite SIM being on a SIM only mon

Try logging into the My EE app on the device that is showing as 'unkown' as that usually updates the system.

 

(make sure you use the My EE app on cellular data though and not WiFi)

by Grand Master
Grand Master

Re: Phone is showing unknown device in My EE despite SIM being on a SIM only mon

Hi, 

 

This function makes no difference to your account so it's nothing to worry about. 

 

If you use the sim it normally updates after a certain period of time, but as I say it makes no difference to your account other than showing a stock picture of the device. 

 

Thanks 




To contact EE Customer Services dial 150 From your EE mobile or 07953 966 250 from any other phone.

EE standard opening hours are 8am to 9pm weekday, 8am to 8pm on weekends.
by abotsford Investigator
Investigator

Re: Phone is showing unknown device in My EE despite SIM being on a SIM only mon

Even when I login as either user on the My EE App on the unknown device it still fails to update the "Device Unknown". I know it not a major issue or affect any usage, i just find it irritating that 2 out of the 3 SIM's work and udate correctly when the 3rd SIM on the account doesn't.

by
EE Community Support Team

Re: Phone is showing unknown device in My EE despite SIM being on a SIM only mon

Hi @abotsford 

 

Thank you for coming to community 🙂

 

Have you got the latest version of the APP?

 

I hope @Northerner put your mind at ease with the last post.

 

Richard

 

🙂

by abotsford Investigator
Investigator

Re: Phone is showing unknown device in My EE despite SIM being on a SIM only mon

Thanks all for the replies, yes I understand it doesn't affect anything but it's just strange it apears to be SIM related. It would have been good to know the root cause even though it's just a minor issue. This affect both My EE on the web and the My EE android app, neither seem to indentify the phone type when the 3rd SIM is installed even after several days. Where my other 2 SIM works fine

 

by
EE Community Support Team

Re: Phone is showing unknown device in My EE despite SIM being on a SIM only mon

I can certainly pass this on to the team and see if I can find anything out for you either way @abotsford

 

Thank you

 

Richard

 

🙂

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.