by Davemartind
Explorer

Talk talk wifi calling

Need some help in the UK please.
Have a Note9 wifi calling works on my phone and network EE when I'm out an about. But when I'm home it wont work on my TalkTalk wifi? I've called my network EE and internet provider TalkTalk an they both blame the other!!!!!

7 REPLIES 7
by Brilliant Contributor
Brilliant Contributor

Re: Talk talk wifi calling

It will choose the strongest signal so if your 4G is stronger than your wifi like it is in my house it wont connect to wifi calling.


BrendonH (Android Expert) Samsung Galaxy S10+ (Pie 9.0)
If I have helped please click the THUMB/SOLUTION buttons below
by Ace Contributor
Ace Contributor

Re: Talk talk wifi calling

Hi @Davemartind

Change your WiFi router channel I will suggest you to change it 11 and then try your WiFi calling.

You look here how can you change channel, 

https://community.talktalk.co.uk/t5/Articles/Change-your-wireless-channel/ta-p/2204684

Thanks 

by
EE Community Support Team

Re: Talk talk wifi calling

Hi @Davemartind

 

Welcome to the community. 🙂

 

The fact that WiFi calling works when you're out and about means that it's fully set up.

 

Let us know how you get on with @tahirmian's advice.

 

Chris

by Davemartind
Explorer

Re: Talk talk wifi calling

Hi all

 

Thanks for the advice so far. Have tried changing channels to 11 an no joy, still not working

 

Thanks

Dave

by
EE Community Support Team

Re: Talk talk wifi calling

Thanks for coming back to us, @Davemartind

 

Have you posted on Talk Talk's community too? As your phone is working on other WiFi connections, it's most likely the way that your broadband is configured.

 

Chris

by Grand Master
Grand Master

Re: Talk talk wifi calling

@Davemartind  Turn on WiFi calling and then enable Airplane Mode you might need to re-activate Wi-Fi on your device but your device will now or should now work via Wi-Fi calling, as mentioned earlier in this thread Wi-Fi calling only works when you have a poor or no cellular signal otherwise it doesn’t work as it’s not needed as you have a good cellular signal.   You don’t need to change any channels on the router at all.    If it doesn’t work after trying what I’ve said above try lowering your firewall setting.  

by PhilipL Established Contributor
Established Contributor

Re: Talk talk wifi calling

Hi

 

It's unlikely to be a Firewall setting on a domestic router as Wi-Fi calling establishes an out going IPSec VPN connection, and out going connections are always allowed.  The firewall is protecting against unsolicited incoming connections only, so shouldn't be adjusted.

 

The problem is likey due to the specific TalkTalk router handing NAT and IpSec traversal, they are known for having issues.  Similar post regarding VPN issues here https://community.talktalk.co.uk/t5/Fibre-Broadband/VPN-Problems/td-p/2307743

 

Hope that helps.

 

Regards

 

Phil

 

 

 

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.