by galorin
Explorer

Trouble with new smart hub. Reconfiguring DHCP server on hub causes problems

I have recently moved from BT to EE, and I have a problem with the network configuration.

 

I have a computer on my network (Raspberry Pi running Pi-hole) that is responsible for network-wide advertisement and content filtering.  It's a basic setup that had been running fine for a over a year while I was with BT.  The way it works is, it acts as an authoritative DNS server, with blacklists and redirects at the DNS level.  

 

In my previous setup, all I had to do was tell the BT HomeHub that, when it handed out its DHCP leases, to set the DNS to the Pi-hole.  Everything worked fine.

 

 

On the Smart Hub, as soon as I change the DHCP server settings, whether just changing the provided DNS servers to point to the Pi-hole, or even any other dns such as OpenDNS or Google DNS, the device stops working.  It is no longer accessible over WiFi, the ethernet-connected devices are no longer able to get DNS, even after issuing a ipconfig /release and ipconfig /renew cycle (refreshing DHCP info). The Hub itself then reports that it can't connect to the internet.  The built-in troubleshooter gets a new broadband username, but doesn't otherwise fix the problem.

 

If I turn off the DHCP server and turn on the Pi-hole DHCP server, then the Smart Hub exhibits the same behavior.  All other ethernet-connected devices are able to get DHCP and DNS from the Pi-hole, but the Smart Hub fails to route traffic.

 

Wifi connected devices in either case begin to treat the WiFi as a captive portal, but with no portal to actually sign in to.

 

Is my device faulty, or is the DHCP server implementation broken by error or by design? 

 

If it is broken through error, I look forward to a firmware update that solves this issue.  If it is broken by design, please explain the rationale that has led to this decision.

11 REPLIES 11
by
EE Employee

Re: Trouble with new smart hub. Reconfiguring DHCP server on hub causes problems

Hi @galorin and welcome to the community.

 

This does sound very unusual.

 

I wonder if @XRaySpeX can offer any suggestions on this one.

 

Many thanks,

 

Lee

by Grand Master
Grand Master

Re: Trouble with new smart hub. Reconfiguring DHCP server on hub causes problem

Sorry, I don't understand this. What has DHCP got to do with DNS? They are entirely diff mechanisms.

 


@galorin wrote:

as soon as I change the DHCP server settings, whether just changing the provided DNS servers to point to the Pi-hole,


What exactly are you changing in the DHCP? It doesn't have any DNS settings, only basically the range of IPs it hands out.

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Thumbs Up" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC
by galorin
Explorer

Re: Trouble with new smart hub. Reconfiguring DHCP server on hub causes problem

@XRaySpeX

 

As part of issuing out a DHCP lease, DNS servers can, and often are specified.  I am not at the machine in question right now right now, but here's what the relevant section of ipconfig /all outputs (Active Directory-managed PC where I was the configuring sysadmin)

 

Description . . . . . . . . . . . : Intel(R) Ethernet Connection I217-LM
Physical Address. . . . . . . . . : F8-B1-56-B3-86-AF
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : REDACTED
IPv4 Address. . . . . . . . . . . : 192.168.101.176(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : 19 April 2018 15:07:07
Lease Expires . . . . . . . . . . : 20 April 2018 00:07:04
Default Gateway . . . . . . . . . : REDACTED
192.168.101.1
DHCP Server . . . . . . . . . . . : 192.168.101.249
DHCPv6 IAID . . . . . . . . . . . : 66629974
DHCPv6 Client DUID. . . . . . . . : REDACTED
DNS Servers . . . . . . . . . . . : 192.168.101.249
10.0.0.31
Primary WINS Server . . . . . . . : 192.168.101.249

 

Under Active Directory, the MicrosoftDHCP server sends out DNS and Gateway information.

 

Under Linux, DHCPd sends out the same information, without which a client, without static information, will not get an IP address, resolve hostnames, or find a gateway address.  Please see

 

https://www.tldp.org/HOWTO/DHCP/x369.html

 

for setting DNS via DHCPD.

 

While they are different services, they are often used together, especially in a domestic environment. 

 

The primary complaint is, the Smart Hub handles handing out DHCP leases, handing out DNS information, responding to DNS requests and routing traffic.  If anything about the default configuration is changed, my device falls over.  Either I should be unable to change these settings, or it should not fall over if I do.  Allowing a change, and falling over completely is not an acceptable state.

by Grand Master
Grand Master

Re: Trouble with new smart hub. Reconfiguring DHCP server on hub causes problem

I'm talking about the router not the ipconfig of your Ethernet adapter (which I agree gets much of its info from the router)

 

Where on the DHCP page of the router is DNS specifed, as you say?

 

Where does a Microsoft DHCP come into it?

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Thumbs Up" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC
by jim3ex Investigator
Investigator

Re: Trouble with new smart hub. Reconfiguring DHCP server on hub causes problem

I have the exact same problem. There seems to be no option to change DNS servers on the EE Smart Hub (not so smart, guys) and the hub wifi has no DNS when you use the Pi-hole as a DHCP server (which will serve itself as the DNS). So, it seems EEs new hub is not compatible with Pi-hole. So, what 3rd party hub can I use on EE fibre broadband?

by jim3ex Investigator
Investigator

Re: Trouble with new smart hub. Reconfiguring DHCP server on hub causes problem

DHCP supplies DNS server address. If you replace the DHCP with Pi-hole server, it will provide its own address as DNS server.

by Grand Master
Grand Master

Re: Trouble with new smart hub. Reconfiguring DHCP server on hub causes problem

@jim3ex: I have told you how to change the DNS on the EE SH in your other thread.

 


@jim3ex wrote:

If you replace the DHCP with Pi-hole server


I don't understand. How can you replace the router's DHCP with something else? You can only either disable it or change its IP range. It has nowt to do with supplying the DNS. The DHCP relates only to the IPs within your LAN; the DNS is on the WAN side.

 

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Thumbs Up" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC
by CarrySheet
Explorer

Re: Trouble with new smart hub. Reconfiguring DHCP server on hub causes problem

The problem is this: You can select a custom DNS server address on the SmartHub (SH) in its advanced settings, but for security reasons the SH will not allow conncetions to addresses in the private IP address ranges, only to public addresses on the WAN side.

 

The workaround for this is to create some additional rules for dnsmasq on your Pi or it will automatically assign the gateway (Your SH) as the DNS server when handing out DHCP leases.

 

On your pi, in the directory /etc/dnsmasq.d/

 

Create a new file 

 

sudo nano 05-custom-settings.conf

 

Add the line below where x.x.x.x is the IP address for your Primary DNS to be handed out by DHCP, in this case, your Pi IP address. For clarity, thats a comma after the 6.

 

dhcp-option=6,x.x.x.x

 

Save and close, reboot. Now for each client device, renew your IP leases on a per device basis to update or wait for them to expire, could be 24 hours.

 

jim3ex and Galorin you were perfectly clear in what you wrote, its a shame the EE staff lack any kind of technical knowledge regarding their own products. I think its worse they then nominate so called community helpers with little networking knowledge to direct the already confused into a state of frustration. 

by Grand Master
Grand Master

Re: Trouble with new smart hub. Reconfiguring DHCP server on hub causes problem


@CarrySheet wrote:

SH will not allow connections to addresses in the private IP address ranges


Does that mean the LAN IPs of your router, i.e. 192.168.1.x ?

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Thumbs Up" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC
by CarrySheet
Explorer

Re: Trouble with new smart hub. Reconfiguring DHCP server on hub causes problem

The Internet Assigned Numbers Authority (IANA) reserves the following IP address blocks for use as private IP addresses:

 

  • 10.0.0.0 to 10.255.255.255
  • 172.16.0.0 to 172.31.255.255
  • 192.168.0.0 to 192.168.255.255
by Grand Master
Grand Master

Re: Trouble with new smart hub. Reconfiguring DHCP server on hub causes problem

Ah, OK, the full gambit of IANA private IP addresses. Thanks.

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Thumbs Up" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.