by Investigator

Smarthub connections



New to EE fibre broadband (around 2 weeks). Everything is running well when devices are connected but getting to connect is painful.


Some devices have to try and connect 3-4 times before getting on wifi. (see phone wifi flashing on/off etc.). Laptop really struggles, have spilt 2.4 and 5 so I swap it around and sometimes that connects easier, no logic to this it can be either 2.4 or 5 causing connection issue at anyone time.


Sometimes devices will connect to wifi but get no internet and just for 10+ mins with no internet.


Wifi plugs are a no go, just wont connect, trying this also kicks phone off. It seems the connect/disconnect process just stops everything and phone will sit there with wifi but no internet.


When devices eventually get connected it works well and is plenty fast enough we just never know how devices are going to connect.


I wanted to ask here if there are any smart/not so features in the hub which could cause this behaviour?



by Grand Master
Grand Master

Re: Smarthub connections

@BAIH wrote:

have spilt 2.4 and 5

Just to confirm, that means you have turned ON Separate the Bands on the Advanced / Wireless Settings page so that the 5GHz SSID  appears starting with "5GHz-" & the 2.4 GHz SSID not starting with "5GHz-"? That's good! 1st thing I'd recommend!


Do you have Intelligent Wireless ON?


What devices are you trying to connect? What are their 802.11 wireless standards?


What does it say after you log into the router on the Advanced Settings / My Network page?

If you think I helped please feel free to hit the "Thumbs Up" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC
by Investigator

Re: Smarthub connections

Yes used separate bands option.


Assume yes to intelligent wifi as not turned it off, where is that option?


will have a look for device info later, but they are android phones x3 (samsung A40, pixel 1 and honor 9 lite), android tablet, chromecast, google mini, laptop, amazon firestick, amazon tablet, 2off sonoff wifi plugs.


I also have am access point connected by cable (tenda f9), devices will connect to this straight away but then still dont get internet straight away. Should add that other devices already connected (same way either 2,4 or 5 or tenda) are getting internet fine.


my network page shows everything connected (once they are) doesnt reference the fact that a device is not getting internet.


by Investigator

Re: Smarthub connections

so have turned auto channel off to static channels 11 and 44 as what i could see as intelligent wifi referenced auto channel selection.


it hasn't made a difference 

by Investigator

Re: Smarthub connections

to update wifi standards- 

sonoff - 802.11b / g / n 2.4G Wi-Fi 

laptop - Protocol: 802.11ac - Intel(R) Dual Band Wireless-AC 7265.

honor 9 lite- Wi-Fi 802.11 b/g/n

tablet - WiFi 802.11 a/b/g/n 

samsung a40 - Wi-Fi 802.11a/b/g/n/ac

google pixel - Wi-Fi 802.11 a/b/g/n/ac

amazon fire - 802.11a/b/g/n

amazon fire stick - 802.11 a/b/g/n

chromecast -  802.11 b/g/n/ac

google mini  - 802.11b/g/n/ac


EE Community Support Team

Re: Smarthub connections

Good Morning @BAIH


I am sorry to hear this has not made a difference. 


Have you been able to contact our home broadband technical department? they will be able to help with further diagnostics.


Speak soon, 


Katie 🙂

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.