by edwardturner
Explorer

Smart Hub port forwarding issues.

I have just set up a smart hub.

Trying to use port forwarding to access servers in home remotely.

I can ssh from within the network but when I use forwarded ports connection times out.
External ports say they are open. But are clearly not actually forwarding the ports.
Have tried with and without the firewall, no effect.

I have also tried different ports, restarting the router different protocols although it should make a difference.

The same settings worked seamlessly with a BB2 that was the previous router installed.

1 SOLUTION

Accepted Solutions
by Grand Master
Grand Master
Solution

Re: Smart Hub port forwarding issues.

Can you address it as:

  1. From without as Raw public IP:xxxx (remove DDNS from equation)?
  2. From within as Raw public IP:xxxx ?
  3. From within as 192.168.1.x:xxxx?
__________________________________________________________________________________________
If you think I helped please feel free to hit the "Star" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC
7 REPLIES 7
by Grand Master
Grand Master

Re: Smart Hub port forwarding issues.


@edwardturner wrote:

I can ssh from within the network but when I use forwarded ports connection times out.


Connection from where? Within or outside the LAN or both? Is ssh the service you are opening ports for?

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Star" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC
Highlighted
by edwardturner
Explorer

Re: Smart Hub port forwarding issues.

From within LAN i can ssh into the machines. 
When i try and ssh from outside LAN i get time out.
It is initially but i will be adding more forwarding rules once i get this working.

by Grand Master
Grand Master

Re: Smart Hub port forwarding issues.

When you are addressing it from within are you using 192.168.1.x:22?

How are addressing it from outside?

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Star" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC
by edwardturner
Explorer

Re: Smart Hub port forwarding issues.

From within LAN as you say: 192.168.1.x:22.

From without ddns set up, which resolves correctly to my ip address, and the forwarded port for a given rule: my.ddns.address:xxxx

 

by Grand Master
Grand Master
Solution

Re: Smart Hub port forwarding issues.

Can you address it as:

  1. From without as Raw public IP:xxxx (remove DDNS from equation)?
  2. From within as Raw public IP:xxxx ?
  3. From within as 192.168.1.x:xxxx?
__________________________________________________________________________________________
If you think I helped please feel free to hit the "Star" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC
by edwardturner
Explorer

Re: Smart Hub port forwarding issues.

I was doing it wrong thanks for advice.

by Grand Master
Grand Master

Re: Smart Hub port forwarding issues.

Thanks! You're welcome :)! Glad I could be of assistance & it is now sorted.

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Star" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC
Let's get started

Join the EE Community to ask, answer, learn and share.