by Greenback Investigator
Investigator

EE Smart Hub Manager - Bug in interface

If you set up access control - and one of the devices isn't currently visible on the network (doesn't have an ip address) - the javascript crashes attempting to convert it IP field to a string, which doesn't allow the changes to be saved.

 

Just managed to accidentally enable block all - with a rule set up which wasn't live.

 

Blocked all internet access - and i couldn't revert back.

 

Had to trace through script and change values to enable the settings to be saved.

1 SOLUTION

Accepted Solutions
by Greenback Investigator
Investigator
Solution

Re: EE Smart Hub Manager - Bug in interface

yes thanks
13 REPLIES 13
by
EE Community Support Team

Re: EE Smart Hub Manager - Bug in interface

Hi @Greenback.

 

Thanks for coming to the community 🙂

 

Have you managed to get it all sorted and save the changes now?

 

Jon

by Greenback Investigator
Investigator
Solution

Re: EE Smart Hub Manager - Bug in interface

yes thanks
by
EE Community Support Team

Re: EE Smart Hub Manager - Bug in interface

That's great @Greenback 🙂

 

Thanks for coming to the community to share your fix!

 

Jon

by toks Investigator
Investigator

Re: EE Smart Hub Manager - Bug in interface

links to this fix appear to have been removed and I am experiencing exactly the same issue with no end in sight.Can the fix please be made available.Thanks

by
EE Community Support Team

Re: EE Smart Hub Manager - Bug in interface

Hi @toks


Welcome to the community.

 

Have you spoken to our Tech Gurus about this?

 

Chris

by toks Investigator
Investigator

Re: EE Smart Hub Manager - Bug in interface

Hi Chris,

 

If by that,you mean the gentlemen over the telephone handling tech support then yes I have,describing the fault earlier we narrowed it down to a software glitch that was disallowing the router from assigning the time correctly(24 hour clock disabled) when operating access control so a new router was dispatched,but once the access controls are operated by myself,all internet access is lost-to all devices-the gents over the phone said it was probably a one in a million freak glitch but the original posters post shows otherwise,please advise.

 

Thanks.

by
EE Community Support Team

Re: EE Smart Hub Manager - Bug in interface

OK, thanks @toks.

 

Has the replacement router fixed the problem or have you not received it yet?

 

We received some similar posts about the Brightbox 2 router last week, where the date and time was incorrect. We reported that and  it was fixed. Smart Hubs were unaffected by this.

 

Chris

by Greenback Investigator
Investigator

Re: EE Smart Hub Manager - Bug in interface

if it's the same software issue that i encountered - ensuring all devices are switched on and visible by the router before applying the restrictions.

 

It's the ones that are greyed out that cause the save to fail.

 

Hope this helps

by toks Investigator
Investigator

Re: EE Smart Hub Manager - Bug in interface

That's an interesting possibility🤔,will give it a try and report back if it works,Many thanks for your help.There are greyed out devices on the list for starters...Hope it works...fingers crossed.

by toks Investigator
Investigator

Re: EE Smart Hub Manager - Bug in interface

Tried this,sadly it does not work,It blocks access to ALL the smart TV's connected to the network,same model but different IP addresses and it does not work even when one specifies the IP address instead of the type of device.

 

Many Thanks.

by Greenback Investigator
Investigator

Re: EE Smart Hub Manager - Bug in interface

Just to clarify  - you have the slider "Disable access to all devices" set to No.

 

Also the times specified is when you want the device to be disabled - so for my kids - i've got it disabled from 7.30pm until 7.30am only on their devices.

 

All devices not specified have access 24/7

by toks Investigator
Investigator

Re: EE Smart Hub Manager - Bug in interface

Ok. It's working properly now.Much appreciated@Greenback-thanks for looking out.

 

Thoughts:I think the problem arises from the clock-this only worked when I set it up in the "am"(this morning) so the routers time and the time being set up were in sync.I followed your guidance yesterday(in the p.m) but the 24 hour clock has stopped reading,it sets up using the 12 hour format whereas the router clock would read,for example :13:45 as opposed to 1:45, the router forces you to put in the latter.Bit bizarre because up until a few weeks ago,the 24 hour clock worked perfectly when setting up access controls and the greyed out devices didn't seem to affect the hub.In any case,it's working now.

 

For now...

by
EE Community Support Team

Re: EE Smart Hub Manager - Bug in interface

Thanks for letting us know @toks

 

Please be sure to come back to the community if you have any further questions, 

 

Katie 🙂

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.