by
Skilled Contributor

Double NAT - BB2 / Asus router

I got fed up with the BB2 router having an unreliable Wifi signal in my house.  Rather tha go through the hassle of gettingn customer service involved, I've bought an Asus router to do the job for me instead.

 

Mostly working fine, and so far the wifi has been more robust.

 

The only issue I've got is that the Asus router prefers to be on a separate subnet to the BB2 (which is providing the fibre connectivity).  So I've got:-

 

EE BB2 router:-

WAN IP - dynamic / external (as usual)

Router IP address - 192.168.1.1

Client devices - only 1 - Asus router - 192.168.1.2

 

Asus router

WAN IP - 192.168.1.2 

Router IP address - 192.168.2.1

Client devices - all wifi / ethernet - 192.168.2.x

 

I've got a device I'd like to make available remotely which I previously had working fine with port forwarding when all of my network was being served by the BB2 router and all were on the same subnet (192.168.1.x)

 

But I think I've now got a double NAT situation which isn't allowing the device to be seen from the internet.

 

I've tried the following:-

Disabling NAT on the BB2 - doesn't work, causes all devices on the network to lose connectivity to the internet

Port forwarding the relevant port on the BB2 to the IP address of the Asus router and then port forwarding to the correct IP address on the Asus router - doesn't work, can't be seen externally

No port forwarding on the BB2 router, port forwarding to the correct IP address on the Asus router only - doesn't work, can't be seen externally

 

Any hints as to how I might get around this?  Worst case scenario is to put the device back onto the BB2 router as a client device, but I don't want to do this as it would mean running multiple SSIDs locally and I don't want to add to the wireless congestion around my area.

 

 

1 SOLUTION

Accepted Solutions
by
Skilled Contributor
Solution
Accepted by topic author larkim
‎14-02-2017 08:37 AM

Re: Double NAT - BB2 / Asus router

Got home, sorted the DDNS entry so that it has the EE WAN IP address in it rather than the daft 192.168.x.x entry and it all works now.

 

Port forwarding set on both the EE BB2 router and the Asus router, and NAT enabled on both.

 

For the moment I'm going to leave it like this, but recognising that having two NAT devices on the same network makes little sense I'll sort it out at some point.  

 

But just a thought - isn't the first device "NAT"ing only from 2.29.x.x to the 192.168.1.x range, and the second device "NAT"'ing from 192.168.1.1 to the 192.168.2.x range?  So isn't that acceptable give the presence of 2 subnets?  Or is it somehow "wrong" where there are only two subnets rather than a true external and internal range?

 

(Anyway, the point is its working for the time being, so its a solution if anyone else was doing something similar, with currently no adverse consequences)

9 REPLIES
by
Grand Master

Re: Double NAT - BB2 / Asus router

[ Edited ]

They should be on the same subnet.

 

Only 1 should have NAT & DHCP enabled (normally the BB2).

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Star" button below.
To phone EE: The local rate landline number 020 7362 0200 or Freephone 0800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC
by
Skilled Contributor

Re: Double NAT - BB2 / Asus router

I don't disagree, as that was what was working when I had an old TPLink router doing the job that the Asus router is doing now.  But the Asus router refuses to play nicely as it points out that the WAN IP that it has cannot be on the same network as the local IP range (which I think we can all agree is correct).  I think the Asus router is trying to be too clever as once there is a WAN / internet "feed" coming into its external port it then wants to set things up "traditionally".

 

I've read other posts elsewhere about this being capable of being overcome through daisy-chaing the port forwarding as I suggested, and I've only just noticed that I'd set up my DDNS settings incorrectly (so the Asus router is telling NO-IP.com that its external address is 192.168.1.2, which is clearly nonsense!) so a little fiddle tonight and perhaps the daisy-chained port forwarding will actually work - certainly when i tried last night it would have been attempting over a 4G connection to find the device with an IP address of 192.168.1.2 which would never work, so I can't honestly now say that I've tried a potential solution properly.  Should have checked that first, but I was knackered last night!  I'll post back if it works (or otherwise) as others may find themselves in the same situation.

by
Grand Master

Re: Double NAT - BB2 / Asus router


larkim wrote:

But the Asus router refuses to play nicely as it points out that the WAN IP that it has cannot be on the same network as the local IP range (which I think we can all agree is correct).


Actually we don't! Cuz the Asus does not possess a local IP range when its DHCP is disabled, as I advised.

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Star" button below.
To phone EE: The local rate landline number 020 7362 0200 or Freephone 0800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC
by
Skilled Contributor

Re: Double NAT - BB2 / Asus router

Aha, that should teach me to read more fully!

 

On the basis that the Asus is the more capable device, I've chosen to leave DHCP to the Asus device rather than the BB2 so I've disabled it on the BB2.  In that config I have DHCP on Asus, but NAT on both Asus and BB2.  If the cockup I've made with the DDNS entry fixed things tonight, then that's the way I'll leave it. 

 

If not I'll try putting the BB2 back in charge of DHCP and disable that on the Asus and see if that works OK.  I think the Asus is capable of different standard modes of operation, so it could be that I need to put it in more of an "access point" mode and tidy things up that way instead. 

 

I'd like the Asus to be the main device as far as possible, but as the BB2 firmware doesn't really expose its ability to "just" be a dumb modem then perhaps I'll have to compromise!

by
Grand Master

Re: Double NAT - BB2 / Asus router

[ Edited ]

If you want the Asus to control everything then you must disable DHCP & NAT on the BB2 & enable them on the Asus. You shouldn't have 2 NATs in operation at once.This way you are using the BB2 solely as a modem.

 

You should make the BB2's Gateway IP on the same subnet as the Asus, if for some peculiar reason the Asus prevents you making its Gateway IP on the same subnet as the BB2, e.g. 192.168.2.2.

 

 

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Star" button below.
To phone EE: The local rate landline number 020 7362 0200 or Freephone 0800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC
by
Skilled Contributor

Re: Double NAT - BB2 / Asus router

Got plenty of time fiddling tonight, I'll let you know.

 

Up to the point where NAT was not working to forward ports etc, everything else was hunky dory, albeit with things that are technically "not right" (i.e. double NAT).  Ideally the BB2 would have an option to be ticked for "bridge mode" or similar which would imply the same sort of setup - one device with NAT / DHCP / management tools etc, and one device which was just sitting there pumping though the internet-juice.  

 

At the very least I'm fairly certain that the wifi performance of the Asus device knocks the spots off the BB2, though having said that the range is broadly the same.

by
Grand Master

Re: Double NAT - BB2 / Asus router

[ Edited ]

Disabling DHCP & NAT = Bridge Mode.

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Star" button below.
To phone EE: The local rate landline number 020 7362 0200 or Freephone 0800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC
by
Skilled Contributor

Re: Double NAT - BB2 / Asus router

Yes, of course.  Perhaps my mistake yesterday was setting the Asus router up whilst the BB2 wasn't in bridge mode (i.e. DHCP and NAT disabled), which is why I've ended up with two subnets.  

by
Skilled Contributor
Solution
Accepted by topic author larkim
‎14-02-2017 08:37 AM

Re: Double NAT - BB2 / Asus router

Got home, sorted the DDNS entry so that it has the EE WAN IP address in it rather than the daft 192.168.x.x entry and it all works now.

 

Port forwarding set on both the EE BB2 router and the Asus router, and NAT enabled on both.

 

For the moment I'm going to leave it like this, but recognising that having two NAT devices on the same network makes little sense I'll sort it out at some point.  

 

But just a thought - isn't the first device "NAT"ing only from 2.29.x.x to the 192.168.1.x range, and the second device "NAT"'ing from 192.168.1.1 to the 192.168.2.x range?  So isn't that acceptable give the presence of 2 subnets?  Or is it somehow "wrong" where there are only two subnets rather than a true external and internal range?

 

(Anyway, the point is its working for the time being, so its a solution if anyone else was doing something similar, with currently no adverse consequences)

Let's get started

Join the EE Community to ask, answer, learn and share.