Need to flash an unlocked EE Samsung S6 - but how?


In december 2016 I ordered a Samsung S6 from EE which was unlocked half a year later. Yesterday the device suddenly decided to go on working only very slow (like missing 90% of cpu power) and it rebooted always when the display turned dark (when switching off by power button). The boot menu options didn't help so tried to flash the device with "Odin" but without any success. I tried it with and without pit file, different firmwares (stock, custom, international) and mostly the flash process failed but sometimes it finished successfully but the device then hangs in a boot process where I can only see the launching splash screen - forever. Also no chance to come into the recovery mode again. Pressing that three buttons (vol+,power and home) doesn't show any effect.

Anyway, I accept the possibility that a hardware damage in memory or mainboard can be the reason. But I still have a rest of hope that I still just didn't find the correct firmware/pit files. Does anyone has an idea? Do I need a firmware for a (EE) branded device or not since it is unlocked? Must it be a UK related firmware or an international one? A one part firmware or four part firmware? 

Best regards


by Brilliant Contributor
Brilliant Contributor

Re: Need to flash an unlocked EE Samsung S6 - but how?

You can flash any EU firmware output for tour particular device



Can't remember the model number for the S6 but I'm guessing G930 for standard and G935 for the edge.


You can't flash a G930 onto a G935.


It sounds like you have bricked it.


If you can't get into recovery mode then you got no chance to getting it done via Odin.


Try plugging it into your PC and use smart switch and initialize firmware.


If it picks it up it will reinstall the original software.


If it doesn't then you have bricked your phone.

BrendonH (Android Expert) Samsung Galaxy S10+ (Android 10/One UI 2.1)
If I have helped please click the THUMB/SOLUTION buttons below

Re: Need to flash an unlocked EE Samsung S6 - but how?

Hi Brendon!

Thank you for your reply!

Luckily I was able to flash a new firmware onto the device and it booted successfully! All is fine again. Smiley Very Happy

I installed a german firmware. I think the point ewas that it was a 4 files containing software and not basing on only one single file. Using the 4 file solution with Odin includes the pit file within one of the 4 files so that there is no additional pit file adding neccessary. (probably that was the neck breaker for me). 

Just check the first three options in Odin (3.12). No additional pit file. And add BL, AP, CP and CSC as different files. That way worked for me. 

Here is a link to the description which helped me. It's in english but if someone find this post via EE search he or she will be so stressed that a Google translation of a german website will be a not to high price. Smiley Wink

By the way: Before the repair I was not able to connect my device to Smart Switch. It was not recognized as a suitable device. 

Best regards


Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.