This page is no longer active
   

For up-to-date information and comments, search the EE Community or start a new topic.

by Bert1 Investigator
Investigator

HOW TO TURN THE POWER OFF on OSPREY

Hi ,

 

I bought the Osprey 4G wifi device on Monday 29th December 2014.

 

It has been working very well and I am glad to have it.

 

I still cannot figure out how to turn the 'Power Off' on the Osprey.

 

Sometimes, if I toggle the On/Off button a few  times I manage to activate the 'POWER OFF'.  Other times, it takes numerous toggles of the On/ Off switch before 'POWER OFF' appears on the OSPREY screen.

 

All comments welcome.

 

Thanks,Cat Happy

3 REPLIES
by PaisleyPat
Explorer

Re: HOW TO TURN THE POWER OFF on OSPREY

I was adivsed by EE that the only way to turn off the Osprey 2 wifi connection is to turn off your computer. I tried this but as soon as you turn the computer back on, the Osprey automatically reconnects to wifi. there is no OFF button on the Osprey.

by smilesnlaughs
Explorer

Re: HOW TO TURN THE POWER OFF on OSPREY

Hi. I have the same issue and have tried to the same on/off toggling but to no avail. I have not yet seen Power Off come up, just the blue lights to show 4G, 3G etc. It is infuriating as this means it loses charge overnight and when you try to get on line each morning, it takes 5-10 minutes to warm up. It is also supposed to allow up to 5 users but when others try, they can see the unit in their wireless list but my password doesn't allow them access. As a business user, this is hopeless. I can't see any technical helpdesk numbers on the site - does anyone know if there is a number I can call? Any assistance gratefully received. Many thanks. Ali
by lindaospreyuser
New Member

Re: HOW TO TURN THE POWER OFF on OSPREY

I really wish I hadn't got an Osprey! Apart from entertaining my grandson on a long journey, I've hardly been able to use it because each time I try the battery's died. It doesn't seem to hold the charge - I thought it was fully charged a few minutes ago but now only 3 / 4 charge showing. Do I have a dud, or is it simply the problem of not having an off button?

Let's get started

Join the EE Community to ask, answer, learn and share.