Highlighted
by Established Contributor
Established Contributor

Wifi Calling not working

Hi, I've just moved over to EE from Three. I got the message that Wifi Calling is now active on my account and it's turned on on my phone but it doesnt say "EE Wifi Calling" on my iPhone X. just says EE. went onto live chat and was told to do a Network reset and turn the Phone off and on again. I've done that but still not working? Any help would be much appreciated.

1 SOLUTION

Accepted Solutions
Highlighted
by Grand Master
Grand Master
Solution

Re: Wifi Calling not working

@Mav_N   Do you have a cellular signal showing on the device if you do Wi-Fi calling will only kick in once you have a poor signal if you have a decent signal Wi-Fi calling will not be enabled even through it might be switched on.  

View solution in original post

24 REPLIES 24
Highlighted
by Grand Master
Grand Master
Solution

Re: Wifi Calling not working

@Mav_N   Do you have a cellular signal showing on the device if you do Wi-Fi calling will only kick in once you have a poor signal if you have a decent signal Wi-Fi calling will not be enabled even through it might be switched on.  

View solution in original post

Highlighted
by Established Contributor
Established Contributor

Re: Wifi Calling not working

Thanks @Chris_B. I didnt know this as I've just moved over from Three on and with them Wifi Calling came on as soon as I was on my home Network so thought it was the same on EE. Thanks again.

Highlighted
by Grand Master
Grand Master

Re: Wifi Calling not working

@Mav_N   that is how it used to work on EE until recently.  Wi-Fi calling used to override all cellular reception but if you don’t need it.   You could put your device into Airplane Mode and Wi-Fi calling with kick in but the only downside is you must remember to turn it off when you go out. 

Highlighted
by
EE Employee

Re: Wifi Calling not working

Hi @Mav_N,

 

I hope the information provided from @Chris_B above has helped.

 

Many thanks,

 

Lee 

Highlighted
by Established Contributor
Established Contributor

Re: Wifi Calling not working

Hi, @Lee_H and thanks for responding. Yes @Chris_B has helped me out thank you.

Highlighted
by
EE Employee

Re: Wifi Calling not working

Hi @Mav_N

 

If you need any further help you know where we are 🙂

 

Many thanks,

 

Lee

Highlighted
by Established Contributor
Established Contributor

Re: Wifi Calling not working

Thanks @Lee_H 🙂

Highlighted
by
Explorer

Re: Wifi Calling not working

Can we have the WiFi calling back to how it was so that it always uses wifi callin when connected to WiFi as we have bad signal at home and the WiFi calling doesn't always kick in when it should.

Highlighted
by Grand Master
Grand Master

Re: Wifi Calling not working

@mileshc  The problem with how it was when Wi-Fi calling kicks in your device is still searching for a mobile network this then drains the battery quicker. 

Highlighted
by
Explorer

Re: Wifi Calling not working

Hi Chis_B, this wasn't an issue for me as I worked from home so would just
pout my phone on the wireless charging pad when needed. Have tried the
solution of putting on Airplane mode and that seems to very successful with
calls so will see how it goes for now.
Highlighted
by Grand Master
Grand Master

Re: Wifi Calling not working

@mileshc   When it was the other way I had to use the airplane mode trick at work as the signal where I am is so hit and miss.  Now it just seem to always connect to WiFi calling as it get very bad cellular signal.

Highlighted
by
Explorer

Re: Wifi Calling not working

This is crazy, i have moved into an area where with not great reception but enough now so that it won't flick over to wifi calling, it is nuts to think i have to keep switching flight mode on and off 

A friend of mine is with Vodafone and has no issues so i thin I might swap to them when the time comes 

Highlighted
by
EE Community Support Team

Re: Wifi Calling not working

Good Morning @GRH

 

Thanks for coming to the community. 

 

What phone are you using?

 

Speak soon, 

 

Katie 🙂

Highlighted
by
Explorer

Re: Wifi Calling not working

Hi

 

iPhone XS Max, i have called through to business support and been told to switch from 4g, VoLTE on to 4g, VoLTE off but that is not ideal 

Highlighted
by
EE Community Support Team

Re: Wifi Calling not working

Thanks for confirming this @GRH

 

Has this improved your call quality?

 

Katie 🙂

Highlighted
by
Explorer

Re: Wifi Calling not working

I have a workaround solution for you guys so that your phone automatically goes in and out of Airplane mode when you are at home or say your office, or somewhere you regularly go where there is poor EE service but you want Wifi Calling to work and have that already turned on.


The answer is iOS Shortcuts applying an Automation rule to use geofencing where Airplane mode is turned on/off when you enter or leave your specified location like Home.

 

Here's the How-to...


With the Apple's iOS13 release and assuming your WifiCalling is turned on. You may need Wifi Assist is turned off for your WifiCalling to work properly. I was advised by EE to do that.

1. Tap the new Shortcuts App in iOS

2. Create Personal Automation

3. Travel > Arrive > Choose Location > Current Location > Done > Next

4. Add Action > Type in the search box air> Set Airplane Mode > On > Next > Done

5. Tap + > Create Personal Automation

6. Travel > Leave > Choose Location > Current Location > Done > Next 

7. Add Action > Search for air > Set Airplane Mode > Off > Next > Done

 

You can even add steps to that so it does say 10 minutes after you arrive in case you arrive at home on the phone and you find your phone cuts out when it enters the area before it picks up your Wifi. So you can add those adjustments as necessary, but now you have automation you can set it up to work for you as needed.

 

Voila!!!!

Highlighted
by Grand Master
Grand Master

Re: Wifi Calling not working

Highlighted
by
Explorer

Re: Wifi Calling not working

@Chris_B interesting I didn't find anything on this, however I have found a fly in the ointment with my solution above and that is the Shortcuts App does not have an 'Always'  setting for its location services, in other words its automation is not automated at all, hopeless Apple blunder!! What it does is instead is it gives you a lock screen notification which if you tap it and then tap Run, it will carry out your "automation" rule, so it only goes halfway, which is incredibly annoying. I wish Apple would somehow streamline its 'Always' options because surely if its always on for say Whatsapp then its the same battery power use if it provides that location data to another app, or thereabouts!! Let's hope Apple wakeup to this blunder of theirs for Shortcuts and then the problem really will be solved in a roundabout way.

Did people really care about the old way which would just switch the phone to WIfi Calling giving you 5 bars, as soon as it was in range of a wifi hotspot?! I didn't. I had the old Vodafone gizmo that enabled that in the home back in the day and it was brilliant. Wifi Calling was supposed to emulate that but now doesn't! You can have a bad signal and still wifi calling will not necessarily work it's a real shame I think. It's lost its value.

Highlighted
by Grand Master
Grand Master

Re: Wifi Calling not working

@ochapple  the simple way is to ask Siri to turn stuff on/off.  

you might find something on one of these.     

https://sharecuts.app

https://shortcutsgallery.com

https://www.macstories.net/shortcuts/

 

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.