by Mel66
Explorer

Voicemail

On my new iPhone 6s I can only receive voicemail alerts when I switch mobile data on-they don’t come through via WiFi for some reason. Anyone know how I can change this??

1 SOLUTION

Accepted Solutions
by Grand Master
Grand Master
Solution

Re: Voicemail

@Mel66   If you’re a contract customer you can enable Wi-Fi calling on the phone and they will come through if you have a poor no signal on your device.  And notifications about missed calls are not sent via WiFi unless you device supports WiFi calling as your a contract customer. It’s a network notification and your device has to be connected to the network to receive the notification. 

2 REPLIES 2
by Grand Master
Grand Master
Solution

Re: Voicemail

@Mel66   If you’re a contract customer you can enable Wi-Fi calling on the phone and they will come through if you have a poor no signal on your device.  And notifications about missed calls are not sent via WiFi unless you device supports WiFi calling as your a contract customer. It’s a network notification and your device has to be connected to the network to receive the notification. 

by Mel66
Explorer

Re: Voicemail

Thanks, that’s really helpful. I’ve enabled WiFi calling now.

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.