by -Douie81
Visitor

I’ve registered for Apple Music add on, but it won’t load up?

Help i’ve Registered for Apple Music add on today, received the text which I followed the direction to verify, but after agreeing to terms and conditions all i’m Getting is a white screen with loading circle, and it won’t move on. Help!

8 REPLIES 8
by Grand Master
Grand Master

Re: I’ve registered for Apple Music add on, but it won’t load up?

@-Douie81   You the 2nd person today to report this.  And looking online it doesn't look like there is an issue with apple music, but this might only be effecting new subscribers so might take longer for apple to sort.   I highly recommend you contact apple as it's their service.

by
EE Community Support Team

Re: I’ve registered for Apple Music add on, but it won’t load up?

Hi and welcome to the community, @-Douie81

 

Could you try following the link this morning and let me know if it works?

 

Thanks

 

Chris

by Lozza94 Investigator
Investigator

Re: I’ve registered for Apple Music add on, but it won’t load up?

Hi there,

 

I am having the exact same problem as the above. I have text 150 and had the link re-sent but I still get the white screen with the loading circle after I sign into my Apple ID. I've had this for a while now and have been trying everyday. I have an account with Apple Music but had cancelled it long before I activated my 6 months free offer so should this still work?

by
EE Community Support Team

Re: I’ve registered for Apple Music add on, but it won’t load up?

Good Morning @Lozza94.

 

Thanks for coming to the community. 

 

If you have cancelled your old Apple account your right this should still work. 

 

Are you connected to Wi-Fi when opening the link?

 

Speak soon, 

 

Katie 🙂

by Lozza94 Investigator
Investigator

Re: I’ve registered for Apple Music add on, but it won’t load up?

Hi Katie,

 

Yes, I have been connected to WIFI when trying to verify the link.

 

Many thanks.

by
EE Community Support Team

Re: I’ve registered for Apple Music add on, but it won’t load up?

Thanks for confirming this @Lozza94

 

Are you able to try verify using mobile data?

 

Katie 🙂

by Lozza94 Investigator
Investigator

Re: I’ve registered for Apple Music add on, but it won’t load up?

Hi Katie,

 

I have just tried doing that now but still the same unfortunately 😞

by
EE Community Support Team

Re: I’ve registered for Apple Music add on, but it won’t load up?

I have sent you a private message for further information @Lozza94, please take a look and get back to me. 

 

Katie 🙂

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.

Recent solutions