by Skilled Contributor
Skilled Contributor

Re: Upgraded to PIXEL 3 from NEXUS 5 - NAT failed via hotspot

It just seemed odd, that using same ip but different gateways and dns. 

 

Can u force the gateway and dns to be same of both devices

 

 

by Doctor_T Established Contributor
Established Contributor

Re: Upgraded to PIXEL 3 from NEXUS 5 - NAT failed via hotspot

15474388119732676349839779880412.jpgPixel 3: settings mimicking Nexus 5

 

15474388827524723168039739842436.jpgPage 2 of settings (same as Nexus for IP, DNS)

 

15474389511497342173798066414798.jpgResult leading to failed internet connection

 

Hello Mirdragon

I edited the connection settings on PS4, when using pixel 3 as hotspot. The same settings on Nexus when using with pixel 3, leads to internet connection failed . (Manual ip input doesnt work). Thanks  for the suggestion. Please all keep them coming 🙂

by Doctor_T Established Contributor
Established Contributor

Re: Upgraded to PIXEL 3 from NEXUS 5 - NAT failed via hotspot

Any help please

by Doctor_T Established Contributor
Established Contributor

Re: Upgraded to PIXEL 3 from NEXUS 5 - NAT failed via hotspot

Here is a partial solution I found on Google but it works for router settings not hotspot, so advice is recommended, how to change settings for point 4?

 

1. Access your modem/router settings by typing the IP address of the modem/router while having internet connection. (i.e. the site usually ends up being http://[enter IP address here]). If you dont know the IP address of your device, connect to the modem via ethernet cable or WiFi and type ipconfig on the  terminal window. The IP address is usually listed in the Default Gateway section.

 

2. Login in to your modem using username and password. (if you dont know this uname and password, ask the technician who set it up or whoever has authority in the house).

 

3. Once logged in, go to the security/firewall settings of your device.

 

4. Change the settings to allow ALL WAN-LAN and ALL LAN-WAN communication.

 

5. Save settings (this is important). Changes are pretty much applied instantly.

 

6. Enjoy your online pvp experience! 

by Grand Master
Grand Master

Re: Upgraded to PIXEL 3 from NEXUS 5 - NAT failed via hotspot


@Doctor_T wrote:

4. Change the settings to allow ALL WAN-LAN and ALL LAN-WAN communication.


Not aware of such a firewall setting on many routers. Which router are you referring to?

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Thumbs Up" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC
by Doctor_T Established Contributor
Established Contributor

Re: Upgraded to PIXEL 3 from NEXUS 5 - NAT failed via hotspot

Sorry don't have a router. I connect via hotspot. Was just searching for options online.

by EeCw Investigator
Investigator

Re: Upgraded to PIXEL 3 from NEXUS 5 - NAT failed via hotspot

Hiya,

 

I have the same problem using EE hotspot from my OnePlus 6T. It used to work with this phone and SIM but now I get NAT Failed when hotspot from my PS4 Pro. 

If I use a BT SIM in this phone, it works fine. Something must have changed on the EE network. 

I read elsewhere they recently changed to IP6?

I can connect to internet. I can play games. I just cannot NAT so this prevents game chat and online play. 

Will update if I find a solution.

by Grand Master
Grand Master

Re: Upgraded to PIXEL 3 from NEXUS 5 - NAT failed via hotspot

@EeCw : Can the OnePlus be forced to use IPv4 only in its APN?

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Thumbs Up" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC
by Doctor_T Established Contributor
Established Contributor

Re: Upgraded to PIXEL 3 from NEXUS 5 - NAT failed via hotspot

That's really helpful. Appreciate the endeavour. I'm still having the same issues. Will update if I find a solution.!

by Grand Master
Grand Master

Re: Upgraded to PIXEL 3 from NEXUS 5 - NAT failed via hotspot

@Doctor_T : Thanks! I suggested that to you 4 months ago in Post 8.

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Thumbs Up" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC
by Doctor_T Established Contributor
Established Contributor

Re: Upgraded to PIXEL 3 from NEXUS 5 - NAT failed via hotspot

Indeed but unfortunately still doesn't work. 😞 

 

Thanks for the suggestion though.

by EeCw Investigator
Investigator

Re: Upgraded to PIXEL 3 from NEXUS 5 - NAT failed via hotspot

Yes I tried that thank you but it didn't work. 

by Doctor_T Established Contributor
Established Contributor

Re: Upgraded to PIXEL 3 from NEXUS 5 - NAT failed via hotspot

Anyone had luck with this fix? Would be nice if you could share it please. 

Thanks 

by Doctor_T Established Contributor
Established Contributor
Solution

Re: Upgraded to PIXEL 3 from NEXUS 5 - NAT failed via hotspot

All sorted. What you need to do is set up an apn. Use ipv4 as soon protocol and use name as ee secure and the rest settings copy from your original APN. Finally ! Taken 7 months!!

Highlighted
by Grand Master
Grand Master

Re: Upgraded to PIXEL 3 from NEXUS 5 - NAT failed via hotspot

@Doctor_T : What did I say to you in post 8 back in January? 

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Thumbs Up" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC
by Doctor_T Established Contributor
Established Contributor

Re: Upgraded to PIXEL 3 from NEXUS 5 - NAT failed via hotspot

Yes you were right. I learnt apart from that that APN needs to be named default, dun and APN type default,supl. Surprisingly how these small nuances make all the difference!

by
EE Community Support Team

Re: Upgraded to PIXEL 3 from NEXUS 5 - NAT failed via hotspot

Thanks for letting us know you got it sorted @Doctor_T 🙂

 

 

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.