by Patrick_Rice Established Contributor
Established Contributor

S8 keeps switching to 2G/3G (auto connect)

Weird one this...

 

Have noticed three or four occasions of late where my new Galaxy S8 seems to be having slow Internet.  When I look, it shows a H or H+ symbol, indicating a 3G based connection. But I just put this down to patchy 4G coverage at that time/location.

 

However a fair while later, in known 4G areas, it is still showing this.  

 

So when I go into Settings > Connections > Mobile Networks > Network Mode I see that it is showing "2G/3G (auto connect)", instead of "2G/3G/4G (auto connect)", thus it is deliberately not using a 4G connection.  I obviously then set it back to this correct setting, and voila! Back to 4G.

 

BUT... I have now noticed it seems to have done this at least three times in recent weeks...

 

The settings to change this are multi-step, as per above, so this doesn't seem to be the sort of thing that I could be easily doing accidentally.

 

Has anyone else experienced this, or is it a known bug in current firmware etc..?

13 REPLIES 13
by Grand Master
Grand Master

Re: S8 keeps switching to 2G/3G (auto connect)

Hi, 

 

This is not normal so try factory resetting and see if that fixes your issue, 

 

Thanks,




To contact EE Customer Services dial 150 From your EE mobile or 07953 966 250 from any other phone.

EE standard opening hours are 8am to 9pm weekday, 8am to 8pm on weekends.
by
EE Employee

Re: S8 keeps switching to 2G/3G (auto connect)

Good Afternoon @Patrick_Rice

 

It definitely doesn’t sound quite right as I'm sure there's no quick settings either to change auto-connect.

 

I would do a back-up and try a factory reset as @Northerner has advised.

 

Try testing the phone first without putting any data back on to see if the issue reoccurs.

 

Let me know how it goes! 

 

Thanks - Karen. Smiley Happy

by Patrick_Rice Established Contributor
Established Contributor

Re: S8 keeps switching to 2G/3G (auto connect)

Alas that's always a two to three week fix process for me, even with Smart Switch, so inevitably, not what I am hoping to have to do as a "worth a try" fix.  Usually followed up with a realisation that I have lost an essential file, contact number, or similar as part of the process etc.

 

For a phone only two month old, that's a bit early to be needing it's first full Factory Reset too, given the time it takes to get fully back up and running.  Usually its at least the six month mark before I will ever contemplate a full Factory Reset.

 

I know its the process of elimination thing, hence your suggestion, but to me those are never real solutions, if they just come back again in due time due to it being an underlying issue.  An example is Google - I pay for a sub to Google Play Music, but since Nougat on the S7, and thus also the S8 I now have, every time I disconnect my phone from my car using Android Auto, Google Play Music won't work again on my car unless I restart the phone.  So their answer was, "just restart the phone".  Alas I do not want to have to restart my phone, every single time I get out of my car for a few seconds, such as to pay for petrol etc.

 

But honestly, as someone who has "restoring all my data and settings back" down to as best an art as can be done, I know that every time I factory reset a phone, I am looking at a very minimum of a full two weeks to get everything back, usually with "not everything" back at that.

 

So was wondering if others had this problem too, or it was a known firmware issue...

 

Hmmm....  I'll keep an eye on it for now maybe, but thanks for the info mate, for sure...

by
EE Employee

Re: S8 keeps switching to 2G/3G (auto connect)

Hi @Patrick_Rice

 

I understand it's a lengthy proccess backing up and restoring.

 

You could try putting the phone into safe mode:

 

  1. Turn the device off.
  2. Press and hold the Power key past the model name screen.
  3. When "SAMSUNG" appears on the screen, release the Power key.
  4. Immediately after releasing the Power key, press and hold the Volume down key.
  5. Continue to hold the Volume down key until the device finishes restarting.
  6. Safe mode will display in the bottom left corner of the screen.
  7. Release the Volume down key when you see Safe Mode.

This will help establish if the issue is hardware or software related.

 

Let me know if this helps.

 

Thanks - Karen. Smiley Happy

by Patrick_Rice Established Contributor
Established Contributor

Re: S8 keeps switching to 2G/3G (auto connect)

Karen, 

 

Many thanks for that suggestion. I'll give this option a definite try if I find it has done it again. 

 

And Northerner, thanks for your input too mate! 

by
EE Employee

Re: S8 keeps switching to 2G/3G (auto connect)

No problem at all @Patrick_Rice

 

Pop back and let us know how you get on.

 

Have a lovely evening!

 

Thanks - Karen. Smiley Happy

by Patrick_Rice Established Contributor
Established Contributor

Re: S8 keeps switching to 2G/3G (auto connect)

Well... 

 

I went to bed last night happily browsing on 4G.

 

Put my phone on charging stand, and woke up this morning to an H+ symbol... 

 

Looked in the Settings, and sure enough, automatically switched me over to 2G/3G Only option.... Grrrr. 

 

I wonder though, if this has anything to do with my overnight timed "Do not disturb" period... 

 

Either way, it's a major bug. So I will experiment more with the suggestions outlined in here... 

 

I'll also ask my wife too monitor her EE S8 too... 

 

But it certainly seems that there is a a potential bug, for a small subset of users (i.e me *lol*). 

 

by
EE Community Support Team

Re: S8 keeps switching to 2G/3G (auto connect)

Hi @Patrick_Rice,

 

Have you activated any power saving settings or used any 3rd party battery management apps?

 

Thanks

 

James

 

 

by Patrick_Rice Established Contributor
Established Contributor

Re: S8 keeps switching to 2G/3G (auto connect)

No not at all. Only the timed  do not disturb feature as mentioned above. this comes on on an evening and switches off on a morning. But it is the Samsung or android based built  in proper do not disturb feature

by Patrick_Rice Established Contributor
Established Contributor

Re: S8 keeps switching to 2G/3G (auto connect)

Unless any built-in power saving feature kicks in when the battery reaches a certain level . But if that is the case then this is still a significant bug as it should revert back once power is of a sufficient level

by
EE Community Support Team

Re: S8 keeps switching to 2G/3G (auto connect)

Thanks @Patrick_Rice

 

I would follow @Karen_C's advice and run the phone in safe mode for 24 hours.

 

If you don't have the problem in safe mode, it indicates a 3rd party app is causing the problem.

 

James

by Patrick_Rice Established Contributor
Established Contributor

Re: S8 keeps switching to 2G/3G (auto connect)

Cheers James I will do when circumstances first allow for that. Much appreciated

by
EE Community Support Team

Re: S8 keeps switching to 2G/3G (auto connect)

No problem @Patrick_Rice

 

Speak soon.

 

James

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.