by Shanehopton
Visitor

Just landed in greece an can't get signal

 
2 REPLIES 2
by Grand Master
Grand Master

Re: Just landed in greece an can't get signal

Hi @Shanehopton 

 

Log into your on line account and then Menu - Manage Device - make sure you have activated roaming and international calls.
Or
From the MyEE app Current Usage - Controls - activate use phone abroad and make international and premium calls

Thanks




To contact EE Customer Services dial 150 From your EE mobile or 07953 966 250 from any other phone.

EE standard opening hours are 8am to 9pm weekday, 8am to 8pm on weekends.
by
EE Community Support Team

Re: Just landed in greece an can't get signal

Hi @Shanehopton

 

Thanks for coming here.

 

This is great advice from @Northerner, can you try this and let us know if you pick up signal?

 

If this does not work for you, can you try and manually connect to a network as below:

 

iPhone – Settings > Mobile Data > Network Selection > Turn off Automatic

 

Android – Settings > More Networks > Mobile Networks > Network Operators > Tap OK

 

Windows – Settings > Mobile Network > Network Selection > Tap on start manual search

 

Speak soon 🙂

 

Leanne.

 

 

Let's get started

Join the EE Community to ask, answer, learn and share.