by elverdiblanco Established Contributor
Established Contributor

Huawei P20 Pro wifi calling

I live in a very poor signal area so wifi calling is a must-have for me. I have the wifi calling option in the phone permanently enabled but the wifi calling indicator rarely appears in the status bar and I know I have missed a few calls because of lack of signal even though wifi calling is switched on and I have a strong wifi signal.

 

It looks like this phone wants to use the cellular network whenever possible regardless of this setting so it seems like it gets 1 bar of signal and reverts to cellular rather than wifi and doesn't switch back when the signal disappears.

 

Is there any way to get this phone to *always* use wifi calling when the option is set regardless of how strong the cellular signal is? If this isn't how it works, why do I rarely see the wifi calling indicator?

 

The phone was supplied by EE so the wifi calling should work.

21 REPLIES 21
by FurstyFerret Contributor
Contributor

Re: Huawei P20 Pro wifi calling

Put it in aeroplane mode and then switch on WiFi?

by
EE Community Support Team

Re: Huawei P20 Pro wifi calling

Hi @elverdiblanco

 

Welcome to the community.

 

The phone does prefer cellular over WiFi calling as this allows you to take advantage of HD calling.

 

As part of the recent software update, WiFi calling doesn't show on your screen when the phone is unlocked (even though it is connected and working in the background).

 

@FurstyFerret's advice would work.

 

Chris

by elverdiblanco Established Contributor
Established Contributor

Re: Huawei P20 Pro wifi calling

Screenshot_20181109-081319.jpg

 

Thanks for the replies.

 

I'm on version 8.1.0.133(C782) and the phone is telling me there are no updates available so I'm assuming I'm on the latest version but as the above screenshot shows it is still showing EE Wifi Calling in the status bar even thought the phone is unlocked. The wifi calling indicator comes and goes, it is not always present. I know for sure that I have missed calls becasue the wifi calling hasn't been active even though switched on.

 

Preferring cellular over wifi is fine if you have a reliable cellular connection but alas that's not the case here, I'd much rather have the phone prefer wifi over cellular when the option is enabled or at least an option to tell it to do so.

 

I'll try the airplane mode with wifi switched on and see how that goes.

by Star Contributor
Star Contributor

Re: Huawei P20 Pro wifi calling

@Christopher_G this appears to be a major issue for a large number of customers.

It seems this system and process is not working as its implemented or intended and its generating posts here and customer frustration.

 

Has this been raised internally and work done to change it?

by EE Community Manager
EE Community Manager

Re: Huawei P20 Pro wifi calling

Hi @Bellyman

 

@Christopher_G is correct in his advice - The phone does prefer cellular over WiFi calling as this allows you to take advantage of HD calling.
 
As part of the recent software update, WiFi calling doesn't show on your screen when the phone is unlocked (even though it is connected and working in the background).

 

It has been fed back to the relevant parties and I am sure that it's under review.

 

Thanks 


Tiff 

Community guidelines Community stars programme




Meet the EE Community teamHow to use the community
by elverdiblanco Established Contributor
Established Contributor

Re: Huawei P20 Pro wifi calling

@TiffJ You said "As part of the recent software update, WiFi calling doesn't show on your screen when the phone is unlocked (even though it is connected and working in the background)."

 

The screenshot I posted earlier clearly shows that's not always the case so this feature isn't working as described. My phone is saying no updates are available so I'm assuming I'm on the latest version of the software. I've also missed calls because Wi-Fi calling hasn't been active even though switched an an in an area of excellent Wi-Fi signal. 

 

I've tried activating airplane mode then switching on Wi-Fi and that appears to be fixing the problem but the Wi-Fi calling indicator is still showing in the status bar. If this is not supposed to be the case why would my phone not be on the latest software if it says no updates are available?

by
EE Community Support Team

Re: Huawei P20 Pro wifi calling

Hi @elverdiblanco,

 

You will still see the WiFi calling indicator in the status bar on your phone's lock screen.

 

When you phone is unlocked and you aren't on a call, you won't see the indicator in your status bar.

 

I've tested this on my EE Huawei P20 Pro running CLT-L09 8.1.0.133 (C782).

 

Thanks

 

James

by elverdiblanco Established Contributor
Established Contributor

Re: Huawei P20 Pro wifi calling

@James_B Look at the screen shot I posted earlier, Wi-Fi calling indicator is showing in the status bar even though the phone is unlocked 

by
EE Community Support Team

Re: Huawei P20 Pro wifi calling

Hi @elverdiblanco,

 

Yes, I noticed that earlier. I haven't had the same experience with the phone I've tested with.

 

Has it just changed recently? Does it display all the time or have you only noticed it once?

 

James

by elverdiblanco Established Contributor
Established Contributor

Re: Huawei P20 Pro wifi calling

@James_B It comes and goes. I can't say there's a definite pattern but it looks like if there is no cell coverage it shows, then if I get 1 bar of cell signal it reverts to cell but when the cell coverage fades again it doesn't come back, nor does the Wi-Fi calling and that's when I'm missing calls. Buy as I said hopefully airplane mode with Wi-Fi on will be fine. 

by
EE Community Support Team

Re: Huawei P20 Pro wifi calling

Thanks for the extra detail @elverdiblanco

 

I'll keep an eye on my phone to see if I notice any changes.

 

Have a great weekend. Smiley Happy

 

James

by HappyFace Established Contributor
Established Contributor

Re: Huawei P20 Pro wifi calling

i think i may be able to answer this.  when you 1st turn on WiFI caling you get the confirmation on the top of the home screen.  lock the screen and you can see WiFI calling as stated.  BUT unlock again and WiFI Calling has gone.  

 

This is an Android implementation to "help" declutter the home screen.

 

So your screenshot is correct directly after activation of the service.  But James is also correct that it's no longer shown like it used to be.

 

 

Highlighted
by eclipse99 Established Contributor
Established Contributor

Re: Huawei P20 Pro wifi calling

I was told on a previous forum that this issue had been resolved with latest update including a oreference selection to choose between WiFi and 4g? I have just bought the P20 Pro on upgrade from EE directly...just run all updates now showing EMUI v. 9.0.0.168 but that option is not showing. If I turn on Airplane mode I get a Wificalling notification but not when I leave 4g on. 

Screenshot_20190318_171024_com.android.phone.jpgAs above

 

by
EE Community Support Team

Re: Huawei P20 Pro wifi calling

Hi @eclipse99,

 

Your phone will automatically switch to WiFi Calling when you don't have a 4G signal.

 

Thanks

 

James

by eclipse99 Established Contributor
Established Contributor

Re: Huawei P20 Pro wifi calling

If only that were the case. It only switches when there is absolutely no signal which means at home and work I'm stuck with a crappy signal usually one bar or less and then have call Quality that is unreliable and poor until I lose signal completely and only then it jumps to WiFi calling. Previous posts said that the software update put up an option to select a preference for either 4g or WiFi when WiFi calling was enabled but I'm yet to find this option. Only reason I finally opted for this phone was that feature would be available.

 

As per the below from the user manual.

 



Sent from my Huawei phoneIMG_20190318_200559.jpg

 

by
EE Community Support Team

Re: Huawei P20 Pro wifi calling

Good Morning @eclipse99

 

Thanks for providing this information.

 

Have you spoke with our technical care team regarding this?

 

Katie 🙂

by eclipse99 Established Contributor
Established Contributor

Re: Huawei P20 Pro wifi calling

Hi, not yet as I wanted to confirm if this was an ongoing issue before I did. Having been told by others that it was but had been resolved by a software update Im not sure if it is a fault or not.

Sent from my Huawei phone
by
EE Community Support Team

Re: Huawei P20 Pro wifi calling

Hi @eclipse99

 

I have had the chance to look at this throughout today, the only way you can force WiFi calling is to switch to aero plane mode. 

 

Thanks, 

 

Katie 🙂

by eclipse99 Established Contributor
Established Contributor

Re: Huawei P20 Pro wifi calling

Not according to others who have posted on here who have confirmed that after an upgrade in software that option was presented under the button which turns on WiFi calling. The stock version of the phone has this option. Not sure why EE would opt, in their build of the operating system have it disabled.

Sent from my Huawei phone

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.

Recent solutions