by I_Thai
Explorer

Hi ppl, can somebody please help me with my Xperia M4?

So the battery died and after charging it, i tried turning it on and the sony logo comes on then switches itself off and on and off and on until i force the shut down. I've even connected the phone to Xperia companion and reinstalled the software which completed without any issues but the phone is still doing the same thing when i turn it on. Please help me somebody, anybody......!

Thank you in advance for any assistance.

3 REPLIES 3
by
EE Community Support Team

Re: Hi ppl, can somebody please help me with my Xperia M4?

Hello there @I_Thai

 

Thanks for coming to the community,

 

Have you been able to try a different charger at all?

 

Did you get the Xperia from EE?

 

Speak soon, Leanne 🙂

by I_Thai
Explorer

Re: Hi ppl, can somebody please help me with my Xperia M4?

Hi Leanne,

 

Yes i have tried a few different chargers and the charging cables with different plugs.

My son bought it from EE a couple years ago and kept it in really good condition so when he bought a new phone, i pinched it for work because i really like the sony phones as i have a Xperia M2 for my personal phone.

 

Kind regards

 

Benjamin

by
EE Community Support Team

Re: Hi ppl, can somebody please help me with my Xperia M4?

Hi @I_Thai

 

It sounds like you've tried everything that we would usually recommend.

 

Due to the age of the device, I think the best course of action going forward it so speak to Sony Support.

 

They should be able to offer the best advice.

 

Let us know what happens.

 

Chris 🙂

Let's get started

Join the EE Community to ask, answer, learn and share.