by david975 Investigator
Investigator

HTC 530 wifi calling

I bought the phone because I have a very weak mobile signal at home, so I want to connect via my wifi Broadband.  It's great when it works, but it seems to keep trying to connect to the very weak mobile signal and lose the very strong wi fi signal, which means I can't make calls and more troubling I don't know when I'm missing calls!  The only way to re-connect is to keep switching the  phone off and then back on, which is a pain.  Any advice on how to keep call over wifi as the default?

 

1 SOLUTION

Accepted Solutions
by
EE Employee
Solution

Re: HTC 530 wifi calling

Hi @david975 and welcome to the Community.

 

Please can I get you to try the following:

  • Reboot your wifi router.
  • Check you have sufficient amount of spare memory.
  • Try wifi calling whilst in safe mode. 

Turn on and use safe mode

  1. Press and hold the Power key.
  2. On the screen, touch and hold Power off under Phone Options.
  3. When the 'Reboot to safe mode' message appears, tap RESTART.
  4. When the phone restarts it will be in safe mode

 

Turn off safe mode

  1. Press and hold the Power key.
  2. Tap Restart.
  3. When the phone restarts it will no longer be in safe mode.

 

Let me know how you get on.

 

Many thanks,

 

Lee

 

 

3 REPLIES 3
by
EE Employee
Solution

Re: HTC 530 wifi calling

Hi @david975 and welcome to the Community.

 

Please can I get you to try the following:

  • Reboot your wifi router.
  • Check you have sufficient amount of spare memory.
  • Try wifi calling whilst in safe mode. 

Turn on and use safe mode

  1. Press and hold the Power key.
  2. On the screen, touch and hold Power off under Phone Options.
  3. When the 'Reboot to safe mode' message appears, tap RESTART.
  4. When the phone restarts it will be in safe mode

 

Turn off safe mode

  1. Press and hold the Power key.
  2. Tap Restart.
  3. When the phone restarts it will no longer be in safe mode.

 

Let me know how you get on.

 

Many thanks,

 

Lee

 

 

by david975 Investigator
Investigator

Re: HTC 530 wifi calling

Thanks Lee.

 

I put the phone in safe mode and it automatically switched on the wifi calling.  I walked out of range of my wifi and obviously lost wifi calling, but when I came back in range again, it automatically connected wifi calling again!

 

I then tried it in normal mode and to my amazement it did the same ie it connected to wifi calling by itself, which it usually only does when I switch the phone off and on again.

 

I have no idea why this worked, but if it continues to solve the problem then you are a genius!

 

I'll keep you posted,

 

regards

 

David

by
EE Employee

Re: HTC 530 wifi calling

Hi @david975

 

Glad you are sorted, I can't take all the credit.

 

@Karen_C is the wifi calling wizard in the office, it was her advice 🙂

 

Do let us know how it continues.

 

Many thanks,

 

Lee

Let's get started

Join the EE Community to ask, answer, learn and share.