by SW2223
Explorer

Galaxy S7 not receiving calls when connected to WiFi

I work on call from time to time. This evening I was contacted via text by a colleague who said the out of hours, service had been trying to call me but couldn't get through. My colleague phoned me from her mobile without a problem.

So I called the out of hours switchboard to check the number they were using (it was correct) and asked them to try calling me back.

The first time they tried it didn't work, then I switched off my WiFi and the next call came through.

I have seen other people having similar issues but cannot find a fix in any of the responses. 

Why is this happening? 

3 REPLIES 3
by Grand Master
Grand Master

Re: Galaxy S7 not receiving calls when connected to WiFi

Hi @SW2223 

 

Are you connecting to EE WiFi calling service when on WiFi?

 

You can disable this service under your dialer settings, if you receive a mobile signal at home you don't need this service active.

 

Thanks




To contact EE Customer Services dial 150 From your EE mobile or 07953 966 250 from any other phone.

EE standard opening hours are 8am to 9pm weekday, 8am to 8pm on weekends.
by SW2223
Explorer

Re: Galaxy S7 not receiving calls when connected to WiFi

Hi Northerner, I do not have WiFi calling enabled. I double checked this after I found out there was an issue with me receiving calls from the call centre. This was posted as a solution in other similar threads as well, but doesn't seem to explain my issue.

I've also checked my other call settings, I'm not rejecting unknown numbers, their number isn't on a blocked list (I would still be able to see that they had tried to call me even if the number was blocked).

by
EE Community Support Team

Re: Galaxy S7 not receiving calls when connected to WiFi

Hi @SW2223.

 

Welcome to the EE Community.

 

Where did you get the phone from?

 

Is it just the one number that you're having trouble with?

 

Jon

Let's get started

Join the EE Community to ask, answer, learn and share.